Fundamental Question on Tag Paths in Easy Chart


I noticed I could generate 4 different possible Tag Paths for a Tag in a Easy Chart Historical, some worked some did not.
Just curious what the use cases are Fully Qualified vs just Tag Path vs [~].

Dragging from Tag Browser(works)
[~]VectorData/Exhaust LEL
Typing in Folder/Tag Name(works)
VectorData/Exhaust LEL
Easy Chart Customizer->Edit Pen->Tag Symbol Leaving Fully Qualified Unchecked(doesn’t return data)
[/ignition-XXXXXX:serialdatatagprovider]vectordata/exhaust lel
Easy Chart Customizer->Edit Pen->Tag Symbol Checking Fully Qualified (doesn’t return Data)
[IGNITIONDEV/ignition-XXXXXX:serialdatatagprovider]vectordata/exhaust lel

My project Settings list “SerialDataTagProvider” as Default Provider
Default Database as “IGNITIONDEV”

I also have an “IGNITIONPROD” DB that I use when I migrate my applications.
I find myself Modifying the Tag History Properties of Tags to point from DEV to PROD when I migrate my applications. Like I am not taking advantage of Default Database?

I think I answered my Tag History Properties Question, it appears like from the Inductive U video that there is NOT a way to specific default Database when configuring Tag History Properties, they always Show selecting from Drop Down. I experimented with leaving it blank, typing in , when I configure Tag History on a Tag.

Can you take advantage of Default Database listed under Project Properties for Tag History Configuration? Or is the Default Database only be used for when you use Tags on Components?

[~]path/to/tag is a shortcut to using the default database. If it’s omitted entirely, the query also assume that you mean the default database, but [~] is our shorthand for "use the default tag provider in place of the ~"

Thanks for the Clarification, PGriffith. I am going back and removing fully qualified Paths.

Can I use the [~] on the Tag Editor/Tag History page?

I tried Leaving History Provider Blank, but it just turns off the History for Tag.

As for my Original Question on why Full Defined Paths were not working for me? I might have found something here