GAN Incoming Connection Issue

Hello Team,

We are trying to establish GAN connection between two server,
But not able to get the certificate for approval under incoming connection.
we tried both ways S1 to S2 and vice versa.

  • Both are able to ping each other.

  • Both 8088 and 8060 port are open we cross check with the telnet.

  • We are not using SSL.

  • Both are connected to single unmanage switch.

  • Firewall is also turn off on both server.

  • Below error get log in logger.

java.util.concurrent.RejectedExecutionException: Task java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask@7baa9ba4[Not completed, task = java.util.concurrent.Executors$RunnableAdapter@71396a1d[Wrapped task = com.inductiveautomation.metro.impl.protocol.websocket.WebSocketConnection$PingWebSocket@4190ddc7]] rejected from java.util.concurrent.ScheduledThreadPoolExecutor@76e50cf2[Terminated, pool size = 0, active threads = 0, queued tasks = 0, completed tasks = 47]

Thanks in Advance.

What versions are the gateways? Are all of the gateway network settings at their defaults (in Config->Networking->Gateway Network and General Settings tab of the web UI) on both systems? Is there a certificate listed in the Diagnostics section on both gateways?

This will help validate that the keystore is valid and was generated/loaded correctly when the gateway started up.

-We are using 8.1.28,

-All setting have default value. SSL check box is clear and we tried with port 8060 and also with 8088.

-We can see certificate listed in both server diagnostics page.

If you've got SSL/TLS disabled on your Gateway Network settings, then you'll need to connect using port 8088.. And consequently, there will be no certificates involved.

Issue resolved

We deleted the "metro-keystore" file both server (path : "C:\Program Files\Inductive Automation\Ignition\webserver" ) and restarting both the server.

Thanks for your support