Gateway Homepage - Error using launch buttons

It tried to search the forum for anyone having a similar issue, but didn’t see it so I will put it up.

Over the weekend I installed Ignition 7.4.3 on a brand new desktop computer. Java 7.4 was installed as the default version from their website. When everything was installed, I tried to use the launch buttons from the home page to open the project, but this resulted in the HTTP 404 ‘requested resource could not be found’ page. The link embedded in the request seemed correct, and when I typed the link in directly (…jnlp), then the project opened and worked fine.

Has anyone else seen this?

I did a little snooping around in the forums and was able to come up with this:


It might be of some use.

The issue was resolved by going into the Gateway Configuration and the Settings tab, scrolling down to the Web-Launch Settings section, and making sure “Direct” was selected on the Launch Link Script Policy dropdown list. It had previously not been set to anything ( or or something similar to that). After this step, everything launched normally.