Gateway issue: Not a valid property name-value pair


I upgraded to Windows 8.1 last week (yeah, stupid me), and now the Ignition Gateway won’t start, even after a reinstall.

The wrapper log reports only this message:

FATAL|wrapper| [date] | The argument ‘Files\Inductive’ is not a valid property name-value pair

Has anyone had this, or know what it means?


If you look at your Ignition Gateway service properties, what does the “path to executable” look like? There may be an issue there with the path to the conf file missing quotes.

“C:\Program Files\Inductive Automation\Ignition”

Nothing has changed since I last worked on Ignition other than a stupid windows update…

Was Ignition working before the 8.1 update? What OS were you upgrading from?

That setting for the Ignition service is wrong, open an elevated command prompt and type this:

sc config ignition binpath= "\"C:\Program Files\Inductive Automation\Ignition\IgnitionGateway.exe\" -s \"C:\Program Files\Inductive Automation\Ignition\data\ignition.conf\""

If your Inductive Automation folder isn’t located in C:\Program Files, change the paths accordingly. Let me know if this fixes things.


Yes, it was working just fine before the update - I spent a full working day doing dev on Ignition, then the next day I did the update. I didn’t actually look at Ignition (or anything else on my computer for about a week), then when I tried to start Ignition I had the issue.

Your solution fixed half the issue, thank you very much.

In addition to Ignition mysteriously changing, Microsoft update also managed to mess up MySQL - in their wisdom, they/Oracle decided to merrrily uninstall the MySQL service - who knows why. In addition, in 8.1, MySQL has suddenly decided to no longer use the C:\ProgramData\ folder for storing the ini file and the databases - it now points to C:\Program Files\MySQL\MySQL Server 5.6\data. Of course, there was nothing in there, because it just moved the pointer and not the actual data.

So if anyone else has this issue, to fix it you need to reinstall the MySQL service, and you need to point it to your ini file:

cd "C:\Program Files\MySQL\MySQL Server 5.6\bin"
mysqld --install MySQL56 --defaults-file="C:\ProgramData\MySQL\MySQL Server 5.6\my.ini"