Gateway "Log in to Continue" loop

Something has happened on our Ignition 8.1 gateway. Any attempt to log in to the gateway results in return to the “Log in to Continue” gateway page.

I suspected that my Chrome browser may have had a cookie issue but other browsers have the same problem. Other users have confirmed the problem.

I’ve stopped and restarted the Ignition using stop-ignition.bat and start-ignition.bat but that hasn’t fixed it. I haven’t restarted the server yet.

Anyone else seen this and have a fix?

You’ll probably have to use gwcmd from the command line to reset the admin account.

Thanks, Phil. I haven’t tried your suggestion yet as I’m not sure that it would be addressing the actual problem which is that the login dialog doesn’t appear. It goes directly to “Log in to Continue” with no log in dialog.

I’ll raise a support ticket and see what they say. Ignition itself is working in the meantime and we can log in to our Perspective applications. (We’re using Ignition - Active Directory hybrid and that’s working.)

It turns out that I created the problem a week before:

  • We’re using AD_internal_hybrid for user authentication.
  • I understand that this automatically creates IdP_AD_internal_hybrid as the system identity provider.
  • I had been aware for some time that a second IdP existed, IdP_AD_internal_hybrid_0, and this must have been created while I played around with the identity providers while originally setting up the system.
  • I deleted the second one about a week ago and thought everything was still working.
  • I discovered today that IdP_AD_internal_hybrid was using “temp” as the user source. Setting it back to AD_internal_hybrid fixed the problem.

I guess that the _0 version of the IdP was the one that was correct and in use.

I did have to use gwcmd –p followed by gwcmd -r to reset the password and let me in.


1 Like