Gateway login timeout

I asked via support email the other day if there was a way to lengthen or eliminate the timeout that logs you off the gateway so quickly. I was told there is not a way to do so and that it was a function of cookies. Is there any way to adjust any settings on my PC to keep it from timing out so quickly. It seems that every time I go from the designer to the gateway to check or configure something, it has timed out and I have to log in again. It’s the little things that can be so frustrating. :frowning:

I was looking through the C:\Program Files\Inductive Automation\Ignition\tomcat\conf file and came across this…

-30

Is this the login timeout I was asking about? And will it hurt anything to change it? If I change it, do I need to restart the gateway for it to take effect?

Bump.

You can try adjusting this timeout, and it will require a restart of the Ignition service. This may or may not work. The amount of timeout before you have to log back in to the gateway probably has more to do with the web browser than anything else. One thing I have noticed is that Chrome seems to log out at a much faster rate than Safari or Firefox. I will test this also. If I notice an immediate negative impact I will advise.

EDIT: One thing to keep in mind, this is for security, if you do change the timeout, keep in mind that you are now making the gateway vulnerable.

Thanks for the reply, Greg. I will experiment with it. Security should not be a problem as this gateway is on a company domain server behind a firewall.

I would also like to setup this Gateway login timeout on my Ubuntu instance of ignition 8.1.3
Is there any similar parameter which is adjustable ?

There is a ‘Remember Me Timeout’ on the IdP that you can set for the number of hours. Example: a value of 720 would expire after 30 days.

that worked, thanks @JordanCClark

1 Like

I tried 720 in that setting, everytime I login the “Remember me” box is unticked, I tick it login, and about 5 minutes later I get kicked out again. 8.1.18 RC1

Mening you have to re-enter your credentials, or are you talking about a session timeout?

Re-enter and tick the “remember me” checkbox again

IIRC, that may be a cookie issue.

1 Like