Gateway name is not persisting upon power cycle

As title;

On 7th at lunchtime I changed my gateway name from 8.1.19 to randdserver. Later that evening I was installing a UPS bypass switch in the server rack so I brought the entire rack down. Upon bringing it up again, the gateway name had changed back to 8.1.19 by itself. So I changed it again.

Then on the 11th, one of my employee’s was adding CTs’ to the UPS PDU, so the rack was taken down again and upon coming back up, once again it has reverted to the old name.

Gateway | ignition8-1-19

Version: 8.1.19 (b2022072711)

License: licensed

Uptime: a day

Running this in Docker if it matters, bare metal is Debian Stretch 10.

Which docker image are you using? I’d imagine it is related, since the --name or -n param you ran the image with is used…

paging @kcollins1 plz

docker run -d --name ignition8-1-19 -h ignition8-1-19 \
  -v ignition8-1-19:/usr/local/bin/ignition/data \
  -p 8119:8088 \
  -e TZ=Europe/Belfast \
  -e GATEWAY_ADMIN_PASSWORD=password \
  -e IGNITION_EDITION=standard \
  -e ACCEPT_IGNITION_EULA=Y \
  inductiveautomation/ignition:8.1.19 \
  -n ignition8-1-19

If you want the gateway system name to “float”, don’t specify it in the runtime args like you are there with the -n flag.

1 Like

You’re doing this to yourself :stuck_out_tongue:

This gets put into data/init.properties and applied on startup.

1 Like

Everyday is a school day :slight_smile:

Thanks both