Gateway Network - 400 Illegal character CNTL=0x15

Hi there, I’m trying to set up a Gateway Network connection between two Ignition servers. I configured an outgoing connection on Gateway1 but I am receiving the following error in the log. I don’t see any incoming connections on Gateway2.

org.eclipse.jetty.websocket.api.UpgradeException: 400 Illegal character CNTL=0x15

Caused by: org.eclipse.jetty.client.HttpResponseException: HTTP protocol violation: bad response on HttpConnectionOverHTTP@180ffe40::SocketChannelEndPoint@5b424b3d{/10.110.34.88:8060<->/10.110.35.70:49723,OPEN,fill=-,flush=-,to=2/30000}{io=0/0,kio=0,kro=1}->HttpConnectionOverHTTP@180ffe40(l:/10.110.35.70:49723 <-> r:/10.110.34.88:8060,closed=false)=>HttpChannelOverHTTP@5585ae25(exchange=HttpExchange@51ba204d req=TERMINATED/null@null res=PENDING/null@null)[send=HttpSenderOverHTTP@14b8a41e(req=QUEUED,snd=COMPLETED,failure=null)[HttpGenerator@5d6a1e17{s=START}],recv=HttpReceiverOverHTTP@25e67719(rsp=IDLE,failure=null)[HttpParser{s=CLOSE,0 of -1}]]

I have an open ticket with Inductive, but thought I’d post it here in the meantime since we have some tight deadlines to get this working.

1 Like

Is one set to require SSL and the other connection not using SSL? or vice-versa?

No, they originally both had SSL required. I then turned SSL off for both to see if that was the issue, but no luck.

So you’ve set “Require SSL” to false on the inbound gateway and then on the outgoing connection from the other gateway unchecked “Use SSL”? Not just set the “Require SSL” to false on both?

I just got off the phone with support. I didn’t realize that if you disable SSL for the gateway network, you have to change the outgoing connection port from 8060 to 8088. It is currently working with “Use SSL” and “Require SSL” both disabled. Thanks!

1 Like