Gateway Network Connection 8.1.3 Windows to Linux

Target server: Amazon Linux AMI (EC2), ignition 8.1.3
Source server: Windows Server 2019, ignition 8.1.3

I ran into problems with this configuration (outgoing connection from windows to linux server) upon upgrading both servers from 8.1.2 to 8.1.3. The linux server became unable to accept the incoming connection. I tried deleting and re-creating the connection, I tried disabling SSL on the outbound side, deleting the certificate on the incoming side, all to no avail.

I was able to re-establish communications by rolling back only the linux server to 8.1.2.

I was unable to find anything in the gateway logs on the linux side under the GAN and web socket loggers that meant much to me, but I did see this on the outbound side logs:

-> outgoing local='<sourceserver>' remote='https://<targetserver>:8060/system' method=outgoingConnect: Connection attempt to wss://<targetserver>:8060/system/ws-control-servlet?name=htpwign02&uuid=3d4c61db-72cd-475d-9148-17e74138a0c7&url= failed! Response code=403, error message=org.eclipse.jetty.websocket.api.UpgradeException: Failed to upgrade to websocket: Unexpected HTTP Response Status Code: 403 Forbidden.

Port 8060 is open on both servers, and I also have several other windows servers running 8.1.3 that are able to open connections with no problems.

I am seeing the same issue only difference is my target server is an AWS Windows 2019 server. But same errors in all the outgoing servers and my target server just looks like a gateway connection has never been established.

I’ve got a ticket open with support and have sent log captures from both sides of this.
Support also suggested trying going the other direction, also to no avail. I also was unable to open a 8.1.3 connection between two Linux servers.

We are having the same problem: we’ve moved from 8.1.2 to 8.1.3 because of problems with redundancy status (with GAN ok, peer missing on Master) but now both gateways cannot see each other. It worked for 2 days but now, either rebooting everything or reconfiguring the redundancy from scratch can fix the problem
Is there any known issue, solution or workaround?

Hello there,

I am having connecting issuses using 2 VM (Windows 10 and Fedora 36). I configured W10 machine as Master, Fedora machine as Backup. I could not get connection between both gateways (ping ok, W10 Firewall off, porst are opened in both machines). SSL deselected. Ignition v8.1.22 running in both machines. Any idea?

My bad: W10 Firewall was not off after all. I set it up off completely and the comm is OK now.

1 Like