Gateway Network Failed to upgrade to websocket after restoring v7.9 backup to v8.1

We are in the process of upgrading several Ignition v7.9 machines to v8.1. Most have been successfully upgraded using in in-place install/installing v8.1 over the existing v7.9 install, however we have a few that have failed this install, so we did ‘fresh’ v8.1 installs and then restored the v7.9 gateway backup to the new v8.1 install. For the most part this has worked except the Gateway Network connections will not restore after the restore. We’ve tried ‘resetting’ the existing connection but it still faults, so we then tried deleting the outgoing gateway connection, deleting the incoming certificate for said machine in the main gateway, created a new outgoing connection in the gateway, approving the certificate in the main gateway, but the new connection continues to fault with the error:

-> outgoing local='a108_gateway' remote='https://172.16.132.28:8060/system' method=outgoingConnect: 
Connection attempt to wss://172.16.132.28:8060/system/ws-control-servlet?name=a108_gateway&uuid=e3cfe14e-e46b-42a0-b6b3-467b4fc9ad55&url=
https://192.168.1.6:8060/system failed! Response code=403, error message=org.eclipse.jetty.websocket.api.UpgradeException: 
Failed to upgrade to websocket: Unexpected HTTP Response Status Code: 403 Forbidden.

The main gateway is successfully connected to dozens of other machines. Any thoughts on what the issue might be/how to rectify it?

Thanks

Approving the certificates worked today so we must’ve just overloaded the main gateway with requests yesterday.