Gateway Not responding in designer

I’m getting a lot of the following mesasges when trying to “save” in the Designer (build 4730)

com.inductiveautomation.ignition.client.gateway_interface.GatewayException: Gateway Error 500: Unable to read response from Gateway. at com.inductiveautomation.ignition.client.gateway_interface.GatewayInterface.newGatewayException( at com.inductiveautomation.ignition.client.gateway_interface.GatewayInterface.getResponse( at com.inductiveautomation.ignition.client.gateway_interface.GatewayInterface.sendMessage( at com.inductiveautomation.ignition.designer.gateway.PriviledgedDesignerTask$GatewayMessageTask.execute( at com.inductiveautomation.ignition.designer.gateway.PriviledgedDesignerTask$ at Source) Caused by: org.xml.sax.SAXParseException: The end-tag for element type "Response" must end with a '>' delimiter. at Source) at$JAXPSAXParser.parse(Unknown Source) at com.inductiveautomation.ignition.client.gateway_interface.GatewayInterface.getResponse( ... 4 more
I never got these before this build. Is it a “Known problem”?

This error simply means that the Gateway failed to respond to some message. The true error will be in the Gateway’s log.

I had a look through the gateway event log around one of the times that this happened & there doesn’t seem to be any “error” messages. What sort of messages should I be looking for in the Gateway Log?

Any log message that is marked as an “Error”. I’m pretty confident that each one of these will correspond to an error message in the Gateway… can you reproduce this problem?

That’s just it. there were no “Errors” logged at the gateway that I could see.

I have since found out that there is a “known problem” with the Router I was using at home.
(using VPN tunnel to company WAN) The problem was “random drop-outs”. Natually enough I no longer use that router. However, we do occassionally (as in not very often) get this same type of problem from the designer within the Company WAN - Still with no “error” type messages being loggged at the gateway. These have only started to Occur since build
(further on when 7.0.6 will be released?)

As far as “reproducing the problem” is concerned I don’t think so. however I did notice that it was more prevalent when saving in the designer when in the “Windows” section of the project browser. (Move to Transaction groups & it will save “nearly every time*” without proplems.)

*Externally via VPN tunnel OR Internally via WAN


That is strange I’ve never seen this error without a corresponding error in the Gateway logs. Can you explain a bit more about the architecture here? Are you running a cluster? Is there more than one designer altering the project at once? If the problem is more prevalent when altering windows: can you isolate the problem to a certain window?

[quote]Can you explain a bit more about the architecture here? Are you running a cluster?[/quote] 1.) I assume you are referring to the “ignition architecture” here? If so, we have a single server (Win2003) that is running both FactorySQL/Kepware/FactoryPMI (the FSQL/Kep/FPMI will be phased out once all projects have been “cutover” to Ignition), and Ignition. A separate Server is being used for the database (MS SQL2005 on Win2003).
2.) Although we have 2 sites both running in the above structure they are not “clustered” nor do they communicate with each other directly (both on different firewalled subnets).

[quote]Is there more than one designer altering the project at once?[/quote]Although we do often have two developers running the ignition or FPMI designers it is seldom that both would be working on the same “project” (this can be a pain if you both need to access the same screen for whatever reason - Saves/Updates/etc.). The majority of the time there is only one designer open & I’m fairly certain that this was the case in all instances of the “gateway not responding” errors.

[quote]If the problem is more prevalent when altering windows: can you isolate the problem to a certain window?[/quote] There doesn’t seem to be any “trigger window” to the problem. I have had it occur on numerous windows with the only common point being that there were changes that needed to be “saved” I.E. windows had been altered. Some of the windows are fairly “complex” in their design & do have a fair smattering of python script throughout but I’m not sure that you’d call this a “big” project or not (it’s about 1.6mb zipped)

I did have a problem with one of the windows becomming “corrupted” somehow (it would load but the components would not “redraw” unless the mouse was “clicked” over them) but was able to correct this by removing the affected window & reimporting from a previous backup of the same project. I could send you a backup of the project but I’m not sure it would do much good without the backend database. Let me know if you’d like a copy of the project (if it would help diagnose the problem further).
As a side note I notice that there is no “Reserialize windows” in ignition… Has this been removed as it was no longer required or not used?

Version 7.0.6 will be released shortly - I’d like to see if these problems persist in the new version.

Also - next time when your windows get “corrupted” - I’d like you to check and see if simply restarting the Designer has any effect or not.

I tried the following befor re-importing the “window”:
1.) restarted the designer
2.) restarted the modules on the gateway PC
3.) restarted the entire gateway PC service
4.) Cleared Java Cache (Client PC) - including removing apps (using Java Control panel)
5.) backed up the project & restored to a different gateway (trial version on local PC)

None of which worked, hence the “Delete” & re-import of that window.

(I have a copy of the project including the corrupted window If it would be of any help)

Wow, yes please send that corrupted copy to us! You can use our upload section if it is too big for email.

Sorry to take so long to respond. I had to get my “permissions” updated so that I could upload the file. :smiling_imp:
I have sent the file via your upload section it is called “UDERSbad.proj” - Note it is a work-in-progress & has changed substantially since this file was created. The window you want to look for is “Deleter”


Update to say I belive this to be fixed in subsequent versions… we no longer have these issues occurring.