Gateway Scheduled Scripts Not Working

I am trying to use the new gateway scheduled script feature that got released in v8.1.6 (currently I am running v8.1.7). However, I am having trouble getting it to run. I am trying to get any script to work and it is not executing.

I am running a very simple script that I KNOW works because I ran it successfully from a gateway timer event script (same project, theoretically running from the exact same scope). That test script is:

	value = system.tag.readBlocking(['[myProvider]test'])[0].value
	system.tag.writeBlocking(['[myProvider]test'],[value + 1])

I also have the gateway scheduled event script currently set to run every minute (so I know I don’t have a weird timezone thing going on), and it is enabled.

I do not see any error messages in the wrapper log file or the status/logs page on the webpage.
All told, this leads me to believe that my script isn’t firing at all. Any thoughts as to why that may be happening?

Hi there!

Facing the same problem here, I’m also using Ignition v8.1.7
Tried different setup for timing but the script will not trigger.

logger = system.util.getLogger("ScheduledEvent")
logger.info("runing")

Any resolution for this one?

Maybe obvious, but is your project enabled?

There were a couple issues with scheduled scripts fixed in 8.1.9. I’d suggest upgrading to the latest 8.1 release and seeing if that resolves it.

Hi zacht, double checked and yes the project is enabled.

Hi Kevin, thanks for suggestion.
I upgraded Ignition server to 8.1.11 but still facing the same problem.
I see that on the gateway > status > gateway scripts the list is empty.
Tried to add a different gateway event (Timer), but the same output…



Well, I tried the same thing using a local Ignition Gateway and seems to work…
Looks like something is blocking my designer changes to be pushed on the remote gateway.

What if you go to status->Logs, do you see running appear under a logger named QOS-onScheduledEvent?

Solved :joy:

The problem in my case was:
In Ignition gateway are defined 2 projects : lib and production (production is inheriting lib)

I did my development in the lib project, which is not runnable as a stand-alone project. It will not create a Gateway Event by itself.

The production project was setup to override Gateway Events…
5

Thanks for the support guys.

2 Likes