Gateway Security General Settings - Error

Freshly installed version of Ignition 8.1.29 on Windows Server 2019. Ignition is running in Trial mode, no license installed.

After the installation process was complete and the gateway up and running. I navigated to Configuration/Security/General and got only the word "Error".

Uninstalled 8.1.29 and installed 8.1.24 as we are able to get to this page on another instance. Same issue.

Has anyone seen this before? Any ideas for fixing this?


Anything in the logs? Can you upload the wrapper.log file?

wrapper.log (37.2 KB)

Hmm, nothing there. You tried to access that page after this gateway session started?

Might need to run this through support instead :confused:

I have tried to access the page several times, same "Error".

What browser are you accessing the gateway with?


The Visual C++ 2015-2022 Runtime libraries were installed, this was recommended for solving the IEC 61580 module error, and the issue is fixed.

It was NOT the Visual C++ Runtime libraries.

Some more information:

  • The Gateway Configuration pages in question work from computers that are on the same network as the server.
  • They do not work from a computer in the DMZ, but all the other configuration pages do work from this computer.

Does Configuration/Security/General use different ports or a different method of communication with the gateway than other configuration pages?

Not surprising. Wouldn't have believed that for a second.

They are among some of the newer React/Javascript pages, instead of older Wicket-based pages.

Someone who knows browser dev tools better than me (@PGriffith maybe?) might have some idea how to troubleshoot it from that angle.

It should just be a pretty standard XHR request. Browser Devtools, open the 'Network' tab, go to the page in question. See if you can see the request to general-security failing for some reason, e.g. here's my successful request on initial page load:

Chrome version 51 was installed on the computer with issues; upgrading it fixed the issues. Thanks for pointing me in the correct direction.

1 Like


That was released in 2016. How did you end up on Windows Server 2019 with such an old browser?

Ignition is installed on Windows Server 2019 on a server on the Process Control Network. We are accessing the web page via an older computer on in the DMZ. Once a system is up and running on the Process Control Network or the DMZ, the upgrade process is tedious.

1 Like