Gateway Service not starting

Ok… another day… another new problem.

Its been a couple of days since I have launched the Gateway Control Utility on my laptop. So… today… I wanted to work on my project… I clicked on the Utility and the pop-up came on the screen and showed that the Gateway was trying to Re-establish connection. I clicked on Start Service… and it would not start… and I got the following message in a box…

The Ignition Gateway Service is starting…The Ignition Gateway Service could not be started. A service specific error occured: 1. More help is available by typing NET HELPMSG 3547.

So I opened a CMD window and type in the Net Help and this is what I got:

Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Tyler Tuttle>net helpmsg 3547

A service specific error occurred: ***.

EXPLANATION

A service-specific error occurred.

ACTION

Refer to the Help or documentation for that service to determine the problem.

… So… got any ideas?? Everything was working fine last time I used the software.

Go into the Services console under Control Panel -> Administrative Tools -> Services and try to start Ignition from there. If it does not start post the contents of the wrapper.log and ignition.conf files in C:\Program Files\Inductive Automation\Ignition\ so we can see what the problem is. Did you remove Java by any chance?

I did not Remove Java.

I had already checked Service Console and the Service was not running. I tried to start it and it would not start. I checked the Windows Event Viewer - system errors… and the Service STOPPED with this description “The Ignition Gateway service terminated with service-specific error 1 (0x1).”

I have attached the files.
ignition_conf.txt (4.91 KB)

I also need the wrapper.log file.

ok
wrapper.log (90.4 KB)

ok… I fixed it… but dont know why it took so long to give me a problem.

Back in April… I read somewhere on the Fourm that you could tell the Gateway how much memory to use… and that you set this in the Ignition Config file. So I was playing around and change the Maxium Java Heap size, wrapper.java.maxmemory=1024 from 1024 to 2048. I thought I restarted the service then and had no problems. I have used the gateway 3 or 4 times, shut my PC down 5 or 6 times and never had a problem, but for some reason today when I started my computer… and it went to run the service… there was not enough memory availiable.

So. … I changed it back… and ALL is Well… Gateway is now running.

Sorry to have sent you looking for a problem I created. Thanks for your help.

Tyler

Regarding the heap size, how do I increase it? I did the same thing ttuttle did- I went to the Ignition.conf file and increased the heap mem from 1024 to 2048, and the gateway would not start.

Fwiw, I’m running Windows 7 with 8GB ram. And, I was having a problem with an app blowing up when the task manager was showing 588MB usage, with the resulting java trace log recommending increasing the heap size:

“Out of Memory
You might want to try the -mx flag to increase heap size”

You can only increase the memory to 1536mb unless you are using 64-bit Java + 64-bit Ignition.

Ahh, good to know. What’s the limit for the 64-bit versions?

Oh, probably somewhere between 256TB and 4PB…

Ok, dumb question- if the gateway is running on a 32-bit machine, and I’m running a client on a 64-bit machine, the memory of the client machine app is still limited by the gateway?

Nope - they’re separate processes. Just make sure to run a 64-bit JVM on the 64-bit machine.