Gateway update script not executing

Hello!
I have a problem. I have a script that reads a shell file and push to a github repos using git-bash.exe.
The script works fine when I run it in the script console but when I try to make it run in a gateway update script when I save the project the script doesn’t run.
I have tried the script out and whenever I run it in the client or outside of ignition it works fine.
I even saw a post about the permissions for the Ignition-service to not run as local system but as the user currently logged in so I changed that but to no avail…

In the gateway its says that the script executed but there is no push to github.
Can someone help me understand this? How can my script run in the client and outside of ignition but not in the gateway update script?

You need most likely to use an absolute path to the file (I.E: c:\data\myfile.exe)
Also, ignition runs under “Local system” user permission and not your user, so
that account needs to have access to that path to be able to execute it.

The absolute path I already have is working, so does the access which I have set to the user and not local system. Everything works, it’s just the gateway event itself that doesnt run the file. It says it’s executing in the gateway but no push is comitted to github

put logs before and after you trying to exectute the shell script.
put logs in the shell script.
Are you sure the shell script is on the gateway and it can run on the gateway?

the shell script is not on the gateway but it is in the ignition directory. I can access it fine from the client with a script but when I try to run it in the gateway script it doesn’t work as intended.
The problem isn’t the shell script as it works fine, the problem is the gateway script. As it is a file I want the gateway to read it using the system.util.execute function.
This also works fine clientside but as soon as I put it in the gateway script, the script doesn’t execute.
How would I put in “on the gateway”?

how are you executing this ‘client side’?

the directory on computer where the gateway service is running?

could you provide the scripts you are using?

yes, the same directory on the computer where the gateway is running.
The script I have is:
import time
time.sleep(5)
system.util.execute([‘C:/Program Files/Git/git-bash.exe’, ‘C:\Program Files\Inductive Automation\Ignition\data\git-auto-commit.sh’])

I have tried this in script console and also on an event fired by a button. Works everytime.