Gateway webpage DHRIO device details shows loading forever

When we tap Details for the first device listed below,

all we get is this:

I’ve left it running for minutes with no change on Ignition 8.1.18 and several earlier versions. I don’t recall for certain if this ever worked or not, but thought it had back in Ignition 7.9.something. We’d like to see the same stats on here as for the Logix driver to see how the ControlLogix bridge-DH+ network and SLC 5/04 are handling the tag requests we’re making. Should this be working, or are no stats expected for DHRIO connections?

Here’s the device configuration, though it seems unlikely there’s anything here relevant to lack of details on gateway webpage:

Does the driver periodically browse the processor if we don’t select the Disable Processor Browse option, or is it only relevant to browsing from Designer?

Should be working. Look for errors in the log.

1 Like

Thanks for confirming, @pturmel. What loggers might be relevant to adjust logging level? I don’t see anything that looks relevant in the logs on gateway web page. There’s nothing logging at the time we attempt to load details page at default info logging levels and the OPC UA, driver adapter, and gateway loggers I set to trace didn’t turn anything up at the time of access either (they are logging lists of reads and occasional writes from operators).

Actually, I don’t have a v8.1 install with this combination. So it might be worth involving support.

Done. I’ll aim to post back here if/when we find a solution.

Attempting to load that page and then downloading a thread dump from another tab may be useful.

1 Like

Done. I took one a few seconds after and then another minute later and sent them via email to ticket #55602.

Josh Hansen in support figured it out. Don’t use special characters in device name. In our case, this device had an ampersand and slash in it. A new connection without those in it worked great. A new connection with an ampersand and slash in name also exhibited forever loading.

Haha, sure, he figured it out :wink:

We’ll get that fixed though.


Haha, to be fair, Josh said we think. I should have said “Josh and unidentified person/persons at IA…” :grin: Thanks @Kevin.Herron!

1 Like