Gateway will not restart after reboot

My machine rebooted over the weekend and I noticed that the gateway did not restart. What can I do to make sure that it always restarts after a reboot? I have checked the service and it is set to automatic.

I got it. I just had to select the Automatic Delay Start setting in services. Apparently the Automatic option itself does not work.