Getting Double Email Alerts when using "Alert On Any Change"

I’m setting up email alerting and I’m getting two email alerts when the “Alert on any change” checkbox is checked. When I uncheck the box I receive only one email message but then the feature to alert on any change is not enabled. I’d like to use the alert on any change feature but only receive one email per change.

I’m using the custom message mode and have added all the alert properties to the message body as a diagnostic step. All values are the same between the two emails. A screen shot of the alerting setup page is attached.

Are there conflicting settings that generate double alert emails?
Thanks in advance!

Well you have the Send Clear set to YES. So you are getting an email when the value goes active and when it is cleared. The fact that the value changed causes a clear of the old alert and an active for the new one.

Thanks for your response. I considered that the clearing might be triggering an email but I’ve an example where the value goes into active alert state and two email alerts are sent. In the body of the custom email I added all properties, one being STATE. The STATE for both messages is active and the ALARM_FLAGS have the same value, 4369, for both messages. If one message were generated by clearing the previous state shouldn’t that message have a state of cleared and the other message have a state of active?

I’ve attached a txt file showing the body of the email (alert properties) and the details from the email’s VIEW->OPTIONS. The only difference between the two emails is the Message-ID. The X-OriginalArrivalTime is exactly the same which seems odd. I’ve xx’ed over some info.
Double-Email-Alert.txt (2.11 KB)

What version of Ignition do you have?

Ignition Platform 7.1.6
SQL Bridge Module 5.1.6
Vision Module 4.1.6
Reporting Module 1.2.6
ActiveX Module 2.0.6

Java Version 1.6.0_21

Hope this covers it.

How many alert notification profiles do you have? Is your email address submitted more than once?

The send clear shouldn’t be a problem- with the “any change” flag, it actually just becomes a flag on the state. That is, there really isn’t any idea of “cleared” on an any change alert- the alert is both active and clear at the same time, because it changed. On analog alerts, you’re really just defining a window in which these on-change alerts are generated- it’s really not about being “active” in the window and “clear” outside of it, like it would be if “any change” was turned off.

Now, to the issue at hand- I can’t replicate the double alert. One thing that’s interesting to me is that the state you’re getting, 4369, means “REGISTER|ACTIVE|CLEARED|ACKNOWLEDGED”. It’s really the “register” part that’s interesting- it means this is coming from a change to the tag’s config. Once the tag is up and running, any changes inside your window should produce state “4368”, ie, no register. Do you still get two messages when this is the case?

Also, let’s look at one thing to narrow down from the start which side the problem is occurring on- the alert generation side, or the email side. Log into the gateway, and go to “Console”. Go to the “Levels” tab. Set the level for “Alerting.AlertBus” to “All”. Trigger an alert, and then go back and look at the console tab. You should see a message along the lines of “Alert published…” with the full info of the alert. Do you see one or two?


In response to Travis:
There is only one profile and my email address is entered only once in that profile.

In response to Colby:
Your point about the REGISTERED bit being set was triggered by me changing settings and trying to debug this problem. After receiving the yours and Travis’ responses, I triggered the same alert, with changing the config and it still generated two emails with the ALARM_FLAGS property set to 4368.
I did as you suggested to show ALL. The logs show there is one alert received, two emails scheduled and two email sent entries in the log. I’ve made a screen shot from the System Console Logs tab.

Ah, yes, we’ve tracked it down. It is indeed sending a separate message for the “active” and “clear” states- and as I mentioned, “on change” alerts are both active and clear at the same time.

To get around this for right now, turning off “send clears” on your “on change” alerts should work.