Getting "Error Writing Tag" on a UDT PB on a Lauch display, but not in play mode


For some reason, you've configured your project to start up with gateway communications disabled. That blocks all tag and database traffic. Look in the project properties in the designer.

I searched the Project > Settings, but don't see that. Where do I look for that

Sorry, under project properties'

Hmm. Misremembered. You can control it for the designer, under the general designer project properties, "Initial Gateway Comm Mode". I don't know how you'd get the comm mode turned off in an actual Vision Client.

that is not good to hear. We are trying to test out the project so we can shop to customer

Try using Find & Replace in the Designer, looking for any calls to system.util.setConnectionMode?

1 Like

not found

That's not how F&R works. Search for only "setConnectionMode", and search in all scopes - you're currently only searching one particular tag provider, not your entire project.

This better?

Change the "Open ...." to "All ...." in each of the resource types that have such a dropdown.

Okay, so there's a Client Event Script, specifically the 'Startup Type', that is setting the connection read-only. That's the problem. Why it's there is up to you and whoever created your project. If you double click that row it'll bring up the script in question.

I assume this should be 3 for read write?

and then restart?

Well, you could read the manual page I linked above :smile:

But the easiest thing to do would be to just comment out that line of script entirely. Vision clients are implicitly read-write unless someone goes out of there way (like this) to make them read-only.

Once you make the change, you'll have to save in the designer which will push a project update to the client(s) you have open. You'll then want to log out and log back in (or just restart them) to get the updated behavior.

Awesome, it works. Thanks