Ghost script (Cached? unwanted)

I have a button running a script. I got an error during runtime in the client that did not seem relevant to my button’s mouse event script. After reviewing my pythong code, I saw that the indicated object was not even being used. I cleared all scripting out of the button events, totally blank now. Saved and ran the client again getting the same results. Is ignition holding on to an old cache of script? This is an issue since after a number of tries and variations, I can no longer have any type of sscript in this button since the client will always run some old faulty script.

Help!

post the error message that you are seeing, also have you tried deleting the button to see if the error pops up with it completely gone? There is a diagnostics window under the help menu of a client that is helpful for debugging.

Error with some of window in background. I am not using to PyDataSet anywhere in my code. I tried it once a month ago and cannot seem to get rid of it.

Interesting you should mention the diagnostics window. I also cannot get my menubar to show at all. I have made the appropriate changes in the project properties and still…nothing.

With button removed. still get exact same error message.

The hot key for the diagnostics window is control+shift+f7. try using find/replace to search all of your scritping to see if you have ‘toPyDataSet’ somewhere you forgot about.

Showing or hiding the menubar in a Vision Client requires a client restart, so that’s normal. As dkhayes117 suggested, use Ctrl+Shift+F7

Looking at the error message popup in the client under the “Message” tab (alternatively, check Diagnostics > Console), do you see the component name? I’m wondering if there is another component on that window (maybe the window itself) that has a mouseRelease script defined, and it’s consuming the mouse click.

OK, so the diagnostic console window shows the same portion of script trying to run. I have also deleted all the Ignition cache since my last reply.

I would still use Find/Replace in the designer under edit menu. Search for ‘toPyDataSet’ and see if the script exists in the project.

No occurrence of ‘toPyDataSet’ using the find/replace utility. Interesting thought. I’m trying to see how far Ignition will take this ghost script. I created a new client and a new similar screen with button and simple script showing a messaageBox(). Still throws exception on ‘toPyDataSet’…!?!

-Leif

The best thing may be to contact Inductive Automation support, if you don’t pay for the support you can still get email support for free at a lower priority.

I figured as much. Will post back to thread with solution.

Support did not help much. I did keep trying to work on this button’s script though and still kept my eye out for the toPyDataSet call. I found it one time and removed it followed by saving everything and getting a gateway backup. No problems since.