Group Mouse Click Events Are Hit or Miss

Hey guys,

I’ve been designing a page under the newest version (7.5.0) and it seems that the mouse clicked and pressed event triggers are really hit or miss on groups of objects.

If I group a bunch of objects and put a mouse clicked event on it to open up a pop up window sometimes it works fine no matter where on the group I click, sometimes it only works when clicking on certain elements of that group and sometimes it just plain doesn’t work at all. FYI.

I tested out mouseClicked and mousePressed events and they work fine for me, what types of objects are you using? Also, for mouseClicked, are you pressing and releasing the mouse in the same spot? Even if you move the mouse slightly between pressing and releasing, the mouseClicked event won’t fire.

I initially used all Mouse Pressed events (only because the mouse click events don’t seem to work well with touch screens) and that showed the behavior that I explained. I then changed them to mouse clicked events and they seemed to do the same thing. I did not pay attention to the mouse movements during the mouse clicked events but I clicked it enough times that it should have worked at least once.

Here is a screen shot of one of the groups as well as the group tree on the left:

and here is the event that I was trying to perform:

Is this behavior occurring only when using a mobile client (touch screen) or does it also occur when using a computer?

On a regular desktop computer, I haven’t tested it on a touch screen PC yet.

I have about 6 of those groups, all with the same elements but in different numbers and configurations. And like I said, some work fine, some work depending on where the mouse was pressed and some don’t work at all. I tried moving elements, removing elements and adding elements into and out of groups and the effect was not predictable. Seems pretty erratic to me (probably not what you want to hear…)

Can you upload a project backup to ticket #7562? Here is the link to upload:

It’ll be better if I can take a first-hand look at the offending object.

Yes I can, I left for the day though so I’ll try to get it first thing Thursday morning.

Project backup has been uploaded.

The problem lies on the Waste Water Main Page in the Waste Water folder, here is the behavior that I am seeing:

On the Sanitary group, the even fires when clicking on the rectangle shape or the sparkline trend but nothing else.

The EQ Tank seems to work when anything is clicked on.

The Bio Filter only seems to work when the sparklines or moving analog indicators are clicked on.

The Clean Water Tank (Reuse) only works when the sparklines and analog indicators are clicked on.

The Effluent Tank only works when the sparkline is clicked on.

The Blowers seem to work with everything but the pictures.

The Nitrification tank does not work at all.

Hopefully you see the same thing and we can track this down… Let me know if you need any more information from me. Thanks!

Sorry for the late reply, but I’m still working on finding the root cause for this. As a workaround for now, if you put a transparent label on top of the group that covers the whole group, and put an event handler on the label, it will work. I will continue to look into this.

No problem, I put the little buttons on each group that they can click on for now so I’m not really in a rush for it.

Turns out there is a bug with labels and mouse events. If you try to add text to the “mouseover text” property of a label, and then delete that text, a “tooltip” property persists in the raw XML data of the component. This tooltip property enables a mouse hover event that intercepts mouse events, which is bad in this case because we need the mouse click to “pass through” to the group, since the event handler is on the group. I have submitted this bug internally, and will keep you updated.

This bug has been fixed for version 7.5.8.