Group Status Not Updating

Hi, I have a redundant FactorySQL system, both communication with Local Rockwell’s RSOPC Gateway. Some groups are trigger based, while other are interval based i.e. every 1 sec, 5 sec etc.

Similarly some are directly bound to tables, while some are bound to stored procedures.

After some time, The group status for all my trasnaction groups Show Execution:0, Erros:0, L:ast Attempted and successful execution as 1/1/0001 12:00:00 AM. No Errors are displayed, the scheduled groups without trigger keep on working but some trigger based groups set to async change stop working. Stopping and Starting the group fixes the issue, so I do not understand what the problem could be.

I am using SQL Server 2000 Enterprise Edition DB. Execution of Stored Procedures is fast enough and I know group executions are not being queued.

Please help


That is indeed strange, that 1/1/0001 date indicates that the groups have not been started, or at least haven’t tried to execute yet.

Is the state of the redundant master changing unnecessarily? If you go to Connection>System Status>Redundancy, do you see many system messages about the state changing? You may try increasing your “Inactive Node Timeout” on both systems to at least 15 seconds, if it’s still at the default 5 seconds.

Another thing to look at would be the “Exec Queue Length” and “Avg Group Execution Cost” under Connection>System Status>Statistics. I don’t believe this is coming into play, but it could lead to these symptoms. The “exec queue length” should be zero, and the “avg. group exec cost” should be low, under 50 ms or so. Anything higher than those could indicate problems.


I do see some messages of unnecessary switchovers between servers but not too many,

I have set the Inactive Node Timeout to a small value of 4 seconds, this was under under the circumstance that the data being logged is too critical and the switchover must happen within very little time incase of failure of any one of the FactorySQL or OPC Servers.

So is 15 second the minimum recommended failover time?

With regards to average group execution time, the groups present in the project vary so much in their usage and logic and well one should not be affecting all of them, I will try increasing the Inactive Node Timeout to 15 seconds and see what happens. Any Other suggestion would be appreciated also.


With a good connection to the database, 5 seconds or less should be fine. However, in practice, we’ve found that 5 seconds often leads to unnecessary switch overs, which is why we’ve been recommending higher lately.

There is one more option that was added recently (4.2.11, I believe) which could help: under redundancy settings, select “always keep project warm”. This avoids a lot of work involved in disconnecting and reconnecting to the OPC server when switch over occurs, which can help things run better. Depending on how much work it was doing, this can help quite a bit.