Having a scrollbar on demand in Vision

Hi,

Is there a way to have a scrollbar appear, if my components do not fit to the window in some resolutions. In this case, the bottom-most component cannot be seen and I cannot use the vertical space, since otherwise we would squeeze everything in HD ( the current resolution is 2K ). I would not want to use the relative layout, if possible.

Thank you in advance!

I believe you should get a scrollbar if your window’s defined minimum size in a given dimension is less than it has available for rendering; that is - set your window’s minimum size to be just enough for your content, and it should automatically render at that size in the client (forcing scrollbars as needed).

2 Likes

Nice screen by the way, I really like that theme :smiley:

1 Like

The problem is that, I have a minimum window size defined. The minimum window size for this instance is set to 1400 and even if I set it to 2500 or down to 1200, the scrollbars do not appear. The resolution for the screen:

image

The window settings:

In the designer it looks like just enough of height for the window.

Thank you @dkhayes117!

do you find any solutions for it?

Unfortunately, no

Hi, any solution discovered for this? I am having the same issue after upgrading to 8.1. This was never a problem in 7.9, the scrollbars would appear automatically.
I have designed screens to fit 1920x1080, and when i launch a windowed Vision client that doesn’t have that full resolution, my components are getting all squished up instead of having scrollbars show up.

Set both minimum width and height.

Hi Phil,

I’ve got size, min, and max of the window in question all set to 1910 width, 900 height and i still don’t get scroll bars.

EDIT: It seems that the setting to change was actually the Project settings under Vision > User Interface > Minimum Size.
Looks like i’ll need to tweak it to get it just right, but at least its working somewhat as expected now.
Thanks!

1 Like

Yes, there is no perfect solution as far as I know. One can either get them to show all the time or not at all. Would be great if there was a dynamic option.