Having difficulty getting a security level rule to work

I’m trying to configure an expression in a Public rule that will enable the level whenever a string tag “Security” is set to “Active” and disable otherwise. A boolean tag would also be an option.

I’ve had no luck trying numerous expressions, my latest attempt being {[edge]Security} = ‘Active’.

The documentation states that the rules can take advantage of everything the expression language has to offer, including the built in expression functions and any Tag values, but I’m skeptical.

Any help with this would be greatly appreciated.

Seeing this error in the log:
IdP Adapter does not exist - invalidating the user

Does the project in use have an Identity Provider configured?

From the Designer’s top menu, select Project > Project properties > General, and then in the Security Settings category locate Identity Provider.


That was the issue, and I’ve moved on to other problems. See my latest topic “Role-based security with remote Edge gateways”

Thank you.
Your answer just saved me!

1 Like