Having trouble running Design Launcher on Linux (Errno 2 No such file or directory: 'x-terminal-emulator')

I’ve been trying to solve this problem on my own but, I’ve gotten to the point where I’m not sure where to go and I was hoping someone on here would be able to give me some insight.

I use a Linux vm for most of my work and until recently was using a Manjaro Linux VM that was working perfectly fine with the ignition Linux packages. I recognize that Arch is not officially supported for Arch Linux, but I have set up an Arch Linux VM that has been working very well with my workflow, while I understand most do not like using a distro like Arch for work, I’ve found that other distros feel very slow to me and after the initial setup, I can clone my VM in case anything happens; it’s just what works for me.

I was able to use the Ignition 8.1.9 installer without any issues, however the Ignition Designer Launcher application has not been working for me. Every time I try to launch it I get “[Errno 2] No such file or directory: ‘x-terminal-emulator’”; I assume that this is because it targets the default terminal in Ubuntu and the other Debian based distros. However, after installing xterm and gnome-terminal the issue still persists. I also tried creating an alias of “x-terminal-manager” for the “xterm” command. I even tried creating a syslink from my installation of xterm to /etc/alternatives/x-terminal-manager (I saw online that this is the default installation location of xterm in Ubuntu.) I would imagine the best idea would be to find where in the program it accesses xterm but I have had no luck finding it so far; of course if anyone has a better idea I would certainly be open to it. Any help would be greatly appreciated!

What is it you’re running? The designerlauncher.sh script in the launcher you downloaded and unzipped from the gateway?

I’ve been running the designerlaucher.desktop file; although I have been able to run the designerlauncher.sh script individually however it did not start the application

Open a terminal, go into the app directory, run ./designerlauncher.sh and post the output here.

Oops, that won’t output anything by default. Hang on…

You could get rid of >/dev/null 2>&1 & on the last line.

I think there might also be output in ~/.ignition/clientlauncher-data/designerlauncher.log.

I got “./designerlauncher.sh: line 20: /home/fas/Downloads/designerlauncher/app/…/runtime/bin/./java: Permission denied”

Does the runtime folder exist? Do you have execute permissions on java?

The runtime folder does exist; I am running this with sudo so I would imagine that it has execute permissions?

There’s no reason to launch the Designer with sudo.

I tried that because of the permission denied error

What’s the output of ls -al ../runtime/bin/ or whatever the relative path to that folder is?

1 Like

drwx------ 2 fas 4096 Apr 27 15:18 .
drwx------ 7 fas 4096 Apr 27 15:18 …
-rw-r–r-- 1 fas 13197 Apr 27 15:18 java
-rw-r–r-- 1 fas 13229 Apr 27 15:18 keytool
-rw-r–r-- 1 fas 13221 Apr 27 15:18 rmid
-rw-r–r-- 1 fas 13229 Apr 27 15:18 rmiregistry

No execute bits set…


So it’s not actually running at all?

You (and nobody else) have permission to execute any files in there.

Change into that dir and run chmod 775 *.

1 Like

Ok so now it’s displaying “Execution faild: designerlauncher.sh
‘’/home/fas/Downloads/designerlauncher/app/designerlauncher.sh’ is not a valid Desktop Entry because line ‘REALDIR=$(cd “$( dirname “${BASH_SOURCE[0]}”)” && pwd)’ does not belong to a group.’”

thats from the .desktop file right?? can you try just running the .sh script in a terminal?

1 Like

It’s working now! I accidentally used the dex command that time to run the .sh file. Thank you guys for all the help!

1 Like