Help please: Unsigned module uploaded, but not running

I am using Linux OS and Ignition 8.1. I just uploaded a 3rd party unsigned module. but state is “loaded” but not “Running”

could anybody please help with this?
Thank you very much.

If your module is only Loaded and not Running that most likely means you haven’t correctly configured the module’s module.xml to define your GatewayHook or don’t have a GatewayHook at all.

You’ll have to share more details for more help.

1 Like

Dear Kevin: Thank you so much for your reply, I tried this and that, but could not fix the issue. Since I am a new user, I could not upload any files, but the pom.xml file I used can be found here:

  1. Gateway
  2. Build
    Since the first time, I installed the module, but the state is faulted. so I changed the scope in pom.xml from G to D, the state turned into loaded, but still not running.
    if you can help, I will really appreciate it. I am working on the neutrino experiment at CERN. Ignition is a very powerful software for data management.
    With best regards

The package names you have declared in code don’t match the actual package structure: