(HELP) sample-MODBUS driver deployed with Eclipse on Gataway

I’m a developer and I and my company are about to develop a new device driver for the ignition’s Gateway.

At the beginning, I was inspecting some of your examples included in the SDK package, particularly the MODBUS driver.

Unfortunately, as soon as I build and deploy the MODBUS Driver v2 onto Ignition Gateway, it happens that the list of the drivers still the same! That is, the gateway displays the old same items, I could see even after the ingnition’s setup.

here you go the steps undertaken:

  • On Eclipse’s Package Explorer, at the node “ModbusDriver_Build”, I launch Build.XML via AntBuild;
  • The module compilation and its deployment on the Gateway succeed! In fact, among the messages of the console, it reports “Installing Modbus driver v2 on Ignition Gateway.” and then"BUILD SUCCESSFUL. Total time: 5 seconds".
  • In the Eclipse’s workspace the file Modbus Drivcer v2-unsigned.modl is successfully built!!!
  • After logged in the Gataway through the web browser, selecting Configuratiuon tab, then, under OPC-UA, clicking Devices and finally, on the left side of the page clicking “new device”, it is possible obtaining the list of the available communication drivers;
  • But here the new deployed driver doesn’t appear.

Any suggestion is appreciated!
Alessandro.

Maybe there is a “conflict” between the version you are building and installing and the modbus driver module included with an express Igntion installation ?

Have you tried to uninstall the included modbus module before installing yours ?

I just have it. Now the module seems be installed with name MODBUS 2.
Thank you Amarth!

But now I can’t understand why the State is:

  • Faulted API version Mismatch

intead of:

  • RUNNING

I’m using the Module SDK version 7.7.5 and the Ignition designer version 7.8.0.
Must they be of the same version number???

[quote=“AlFaSoft”]I’m using the Module SDK version 7.7.5 and the Ignition designer version 7.8.0.
Must they be of the same version number???[/quote]Yes and no. The key is the requiredframeworkversion property in module.xml. That has to match the platform. v7.8 uses framework 7. v7.7 uses framework 6.
Consider using the maven-based sdk hosted on github.

Hi,
I’ve just downgraded the Ignition platform back to the version 7.7.0 .
The ModBus driver I found in the bundle SDK 7.7.5 seems be properly deployed and finally runs in the gateway.
Thank you Phil!!

Other questions:

  • Is the framework brought by Ingnition’s setup?

Among the components shown at Ignition Designer -> Help -> About … I can’t see a component named “framework”.

  • Therefore, how could I get the framework version?

Regards,
Alex

It’s in module.xml in your project’s build folder.

SRContext contains the FRAMEWORK_VERSION constant should you ever need to reference it programmatically. For simple reference: here are the frame versions and how they relate to Ignition API Versions.

7.0 = Framework version 1
7.1 = Framework version 1
7.2 = Framework version 2
7.3 = Framework version 3
7.4 = Framework version 4
7.5 = Framework version 4
7.6 = Framework version 5
7.7 = Framework version 6
7.8 = Framework version 7

The API is generally stable for backwards compatibility. Versions are changed only when we make additions, so if you have a 7.7 module, you should be able to rebuild it with the framework version 7 tag (or simply change the module.xml as Phil said) and be good to go.