Help setting up IP camera viewer

Could someone help me out with setting up IP camera viewer please?
I'm using Axis M3116.
video mode is mjpeg stream with authentication
I am using ctrl C and ctrl V to copy from the camera internal web to IP camera viewer URL.

this is the url http:/xx.xx.xx.xx/camera/index.html#/video

and the error I got is:
IOException: Stream is not an MJPEG stream.
and this is in the output console
21:53:53.251 [IPCamViewer-FrameProducer] WARN Vision.Components.IPCamViewer - Content type "text/html"in unexpected format. Unable to detect boundary string.

Thank you in advance

That error means one of two things:

  • That isn't the right URL for MJPEG, or

  • You didn't pass the right authentication, and the camera is attempting to show an authorization page.

Generally, you would include the user name and password in the URL, like so:


Since the URL has .html in it, I suspect that it isn't the right URL at all.

Would you give me a hand with this?
I am trying to find the right URL but not sure, which is which. This is the source codes of the webpage that showing the live feed. Also running into issues of posting the source codes here.

//<!doctype html>AXISJavaScript is disabled or not supported by the browser. To use the Axis web application, enable JavaScript.


I don't have any Axis cameras.

Historically, I've used a browser's inspector tool to examine the DOM of the browser while the video was up and playing, to examine the iframe and/or video component for the source it was playing at that moment.

But then, I'm typically looking for an RTSP URL to put into my streaming module, not an MJPEG URL for direct use in the IP camera viewer component.

I recommend you test stream URLs with VLC so you can verify what they are really delivering.

Just wanted to add in here, that using the Browser to view the URL was how i got it working with my Axis Camera. the one catch to remember other than credentials, is that the camera URL default was H.264. Once i switched it on the web browser to MJPEG, it started working as needed.