Hidden Transaction Groups

I have 3 transaction groups that are some how hidden and running and I am unable to delete them. I can export/import them but they still don’t show up. Attached is the exported transaction groups. Is this an Ignition issue or ID10T error?
TG.proj (11.6 KB)

Wow! Even importing them, they’re invisible! That’s cool! Annoying, but cool! :laughing:

This is on my list of long shots, but it seemed to work on my test bench.
Also, this may be a bit on the dangerous side. No warranty is expressed or implied. You’ve been warned… :stuck_out_tongue:

If you take a look at the file you posted, each transaction group has a line that looks something like this:

	<resource id='176' name='Stop' module='fsql' modver='' type='group' ver='0' dirty='true' editcount='2388' parent='a5b11ec0-dc9c-4a8e-8117-46edb4ef089b' oemlocked='false' scope='1' protected='false'>

The parent parameter (speculation here) is what folder a transaction group belongs in.
Try setting the parameter on each to an empty string (parent=’’) then re-import, overwriting the originals.

Yeah, the other annoying thing is one of those is logging to SQL every minute.

I tried importing and deleting out of a test project and it works, but can’t do the same in the original project that created them.

It’s why I called it a long shot. :scratch:

Option B might be to:
–Export the complete project
–Remove those three groups out of the xml
–Import into another project.
–Delete original project.

Kinda messy, IMO, but it would likely work.

I tried exporting the Transaction Groups to XML but they don’t show up in the XML file. Option B is gonna be real messy.

Do the transaction groups show up in the project resources table in the internal tables? You could delete there then restart the server.

That did it Kyle. Thanks for the help.