Histogram in DateRange flickering

I have copied the Alarm History page from the IADairy example project and altered it to work on my Alert Storage table. My problem is that I cannot get the Histogram feature to work in the date range. I have an SQL query for the Data Density that is:
where ACTIVE_TIMESTAMP between Date Range.outerRangeStartDate and Date Range.outerRangeEndDate

The small orange lines briefly flicker in the Date Range, the query is set to Relative, have tried “Off” but this does not solve it. If a put the same query in a Table the table populates with a column of timestamps so the query is good. :scratch:

Try removing the where clause from the query. You want to show all timestamps possible.

Thanks. Tried this on a small project (at home) and it seems to work as it should. I would point out that I copied the method from the Igntion manual quoted below:

“To use this feature, bind the Data Density dataset to a query that returns just the timestamps of the target table. These timestamps will be used to fill in the histogram behind the timeline. You can use the Outer Range Start Date and Outer Range End Date properties in your query to limit the overall return size for the query.”

Does this make the statement in the manual incorrect as I believe I followed the above correctly? Would be nice to fully understand the above as it seems to make sense what is says about limiting the data.

No, you can filter the query using the date ranges. However, I think in your case it wasn’t returning the right values. You would have to post the exact query and a screenshot of the actual data in the dataset.

Here is a screenshot which also contains a table displaying the result of the histogram query, and here is the exact query:

where ACTIVE_TIMESTAMP between ‘{Root Container.Alarms.Options.Date Range.outerRangeStartDate}’ and ‘{Root Container.Alarms.Options.Date Range.outerRangeEndDate}’

I got rid of the where clause on the work laptop and the problem still exists. The copy of Ignition I am working on is now installed on a virtual machine that sits on a “host” laptop that has Ignition on as well. When running on the host Ignition failed to connect to gateway when browing for SQL tags, this is why I installed on a VM (the VM browses and is 10 quicker when launching designer or client???). Could this be caused by my messed up laptop?