Historian records values that do not change

Hello folks,

I’m trying to figure out why my historian is recording series of 0, seemingly randomly.

I tried this in the script console:

data = system.tag.queryTagHistory([path], rangeHours=48, ignoreBadQuality=True)
for row in system.dataset.toPyDataSet(data):
print "with ignoreBadQuality: {} events".format(data.getRowCount())

data = system.tag.queryTagHistory([path], rangeHours=48, ignoreBadQuality=False)
print "without ignoreBadQuality: {} events".format(data.getRowCount())

I tried the ignoreBadQuality thing to see if maybe it was logging changes in quality.
here’s the end of the output:


And the config:


Now, I was monitoring this tag because the only non-zero value it got, 24383, should never happen. And it happened 3 times over the last week. I suspect hardware issues at this point, but that doesn’t explain why the historian would record unchanging values.

Any clue ?

Are you writing to configuration properties that might restart the tag?

I’m not aware of anything of the sort. Not from the scada.

One thing though: All the tags coming from that device seem to show the same behavior. But not at the same timestamps.

Maybe something wrong with the hardware…