Historical Transaction Group - Subquery returned more than 1 value Error

Hi All,

I need help resolving an issue with a historical transaction group I have set up. Every now and again, about once every 50 records, I get the error: Subquery returned more than 1 value.

In the Store and Forward quarantine I have tried removing various data and found that if I remove a certain string column then the query will be successful.

Here is the quarantine output:

<?xml version="1.0"?>

<}cachedata sourceStore=“BELGM” creationTime=“Thu Sep 30 07:43:33 AEST 2021”>
<}data flavor=“datasourcedata” subtype=“record”>
<}record table="[tBEL.GM.Sorter.StackerOut]">
<}col name=“AveDensity” type=“java.lang.Integer”>618
<}col name=“AveMOE” type=“java.lang.Integer”>5,531
<}col name=“Bay” type=“java.lang.Integer”>52
<}col name=“Grade” type=“java.lang.String”>Heart
<}col name=“Length” type=“java.lang.Integer”>4,200
<}col name=“NMI” type=“java.lang.Float”>0
<}col name=“RackNumber” type=“java.lang.String”>AC27055
<}col name=“Tally” type=“java.lang.Integer”>12
<}col name=“Thickness” type=“java.lang.Integer”>75
<}col name=“Volume” type=“java.lang.Float”>0.7560001015663147
<}col name=“Width” type=“java.lang.Integer”>200
<}col name=“EnableM12” type=“java.lang.Boolean”>false
<}col name=“SplitBinRack” type=“java.lang.Boolean”>false
<}col name=“DT1” type=“java.sql.Timestamp”>2021-09-29 12:08:07.110

And the row I remove to get it to work is:
This text will be hidden

'<}col name=“RackNumber” type=“java.lang.String”>AC27055

Any help will be appreciated.

Hi All,

I have an update. I tried using a standard group for the same tags - I just copied all the tags from the historical transaction group into a standard transaction group and made all the settings the same and I haven’t had this issue since. I’m not sure what caused the historical transaction group to fail where as the standard trasaction group was successful.