How to escape charactor [#] in ignition.conf

I add password of an account, and the password likes [pass#word], I cann't see #word in debug logs, how do we handle this case if we don't want update my password.

I tested with java, it's going to create [\#] when we save configurations to properties file, it dosn't work even I add \ before [#], any idea would be great.

Looks like you may need two backslashes.

No, it should be one, because I just need #word

Jordan means:

1 Like

Yeah, I got it, but it shows (Password: pass\) in wrapper.log as well

There are other suggestions in the stack thread, e.g.


Try them.

It seems kind of format, would you please provide more details in my case?


You either quote the entire value or include a second ‘#’.“my#password”

Solution for me.

Hello Kevin,

It worked perfectly days ago, it's not working after we change password of share drive.
New password is ^bE9Q$hSf430Th3R

I tried map it manually, it works!
I checked logs and it prints account and password correctly.
With new password it maps drive successfully but has no access to share folders, do you know what's going on, how do I handle this issue?

I would redact that password if I were you. Probably not the sort of thing you want shared publicly. If you think you need the type of assistance where someone may need the password you should call support.

No worries, I hide some charactors already

Did you change the password while the gateway was running? I have found that if a gateway mapped drive connection gets broken while it's running the only way to re-establish it is to restart the gateway (assuming you have the new password in the .conf).

Yes, Stop then start couple times, I just don't know why it works on my local but not on server.
I assume it will have access to folders if it maps successfully.

Any ideas?

I restart server it doesn't work still, then I stoped and started ignition service it works finally.