How to make a perspective table text column not wrap

I have a perspective table populated by a named query on the data binding. The last column is a pretty large xml-ish text string that makes the whole column much taller when really I would rather it just go to the right. I would even be ok with it being truncated as long as when a user tries to copy it the full value comes through - this is necessary.

It looks like this -

I don’t know how to make this work with the column settings. I’ve tried render: string and a few of the other check boxes but I can’t seem to get it working. I don’t know if this is something that require some CSS magic.

Right now the only thing that seems close to doing it is setting the width to 40,000 but after that nothing more seems to happen at higher numbers and I still have about 4 rows of text. I know, its a very long string.

Any ideas on how to rectify this?

See if Perspective Table Row Wrap - #2 by weisenbergerm works for you.

1 Like

Awesome. Any way to then add a horizontal scroll for the whole table?

Oddly enough I have another table in another tab that seems to have a horizontal scroll bar but all the props look identical.

I had to put the column name under the column field, set the width to strict, and put it to 16,000 pixels and it works. In case anyone needs to know.

  1. What container type is your table in?
  2. What’s the width of the container?
  3. Check the view’s PROPS.defaultsize.width.
  4. Check the table’s POSITION.grow, POSITION.shrink and POSITION.basis settings.

See how they’re set in the one that looks right and copy them into the problem table.