HTTP Post gives odd error when tried in a gateway context

I have a URL, a JSON string, and a desire to post that JSON string to that URL with MIME type application/JSON. So I do this:, "application/json",system.util.jsonEncode(payload))

where payload is the python dictionary, and url is the post URL. I’ve tried this in the script console, a version of it in Postman, and both work fine. However, it doesn’t work when I put it in a gateway timer script. I get an error like this

com.inductiveautomation.ignition.common.script.JythonExecException: Traceback (most recent call last): File "", line 41, in IOError: Error constructing implementation (algorithm: Default, provider: SunJSSE, class:$DefaultSSLContext)

where line 41 is the httpPost() line above.
Googling hasn’t really gotten me anywhere; anyone know whats going on here? Also, I’m on 7.9 (with no 8.0 in sight just yet) so I can’t use the fancy new httpClient() :frowning:

Edit: if it matters, it is an HTTPS url. I don’t believe there are any authentication requirements; I posted just fine without any on the script console & Postman.

Are you using different versions of Java for the Ignition Gateway and the Designer?

On the gateway, java is 1.8.0_121-b13
On my client/designer, java is 1.8.0_221-b11

Hmm. Well, it might be worth trying to update the gateway to the latest version of Java 8.