I can't run the designer

I have Ignition 7.4.2 installed in a PC with windows 7 32, and Java 7. All was going well until 4 days ago, when I tried to start the designer but it didn’t start. Could you help me to solve this, please? :prayer:


Ok, what happens when you try to launch? Have you tried clearing out the Java cache? What changed 4 days ago?

I’ve installed Java 7. Now I uninstalled Java 7 and installed Java 6 and the designer runs without problems. Is Ignition still having problems with Java 7

I’m guessing the problem actually lies in a configuration file that is still pointing to the old version 6 install vs looking at the newer version 7 path. Is this a 64-bit computer?

At first, Ignition couldn’t start because that problem, but after pointing configuration to the new Java path I had problems runing the disgner

Is this related to the issue you posted about here: Apache Tomcat error

If so then try what I suggested there and let me know if that fixes your issue.

No, it’s not related to that issue.

Do you get any error messages when trying to launch the designer? Does it download the jnlp file successfully and do you see the Java 7 splash screen pop up at all?

No, I don’t get any error message. When I double click on the designer’s icon appears the Java logo (as normal) but the designer doesn’t start.


This is rather odd. I do know that the designer takes considerably longer to launch under Java 7 than it did with Java 6. When I say considerably longer, I really do mean quite a bit longer. So much longer on some systems that you may think that it’s not actually opening. Eventually however it does actually launch.

If the designer is indeed failing to launch under Java 7 (even after waiting a while) then you may have to call into tech support so we can take a look at what’s going on.

When I launched the designer I waited for more than 10 minutes. For now I don’t have any problems because I’m using Java 6 again. If someday I do an upgrade Java 6 to Java 7, am I going to have problems again with the designer?

We have lots of customers running Java 7 at this point, and we test it here in-house, so I can say that this isn’t a common Java 7 issue. The time delay launching for Java 7 is an additional 20-40 seconds, and you would have gotten to our loading screen first anyhow.

Perhaps you could enable the Java console from your Java control panel and launch again, you might get more diagnostic information?

I haven’t had more problems opening the designer with Java 7. Maybe it was something about my Java config… thanks! :thumb_left: