IE "Internal Error" trying to activate license

I am using a thin client with Windows Embedded Standard on it. It does not have an internet connection so I am trying to get the activation request file. When I enter the CD-Key and press Enter IE just displays “Internal Error” with a Return to Home Page link. I have done this procedure before on Windows XP and it worked just fine. IE is version 8.

Hit the “alt” key, and see if work offline is selected under the file menu. If so, un-check it.

Do you have another browser installed (Firefox, Chrome, Opera)?

Work Offline is not checked, and there is no other browser installed.

I would take a quick look at the wrapper.log file in the Ignition install directory to see if there really is, in fact, an ‘internal error’ occurring.


Actually, I just re-read your post and noticed the ‘XP embedded’. I’m pretty sure that this is not supported, though it may work with the latest 7.1.8 beta. If you see an error in the wrapper, try downloading the beta and giving that a try.


I will check the wrapper.log file on the thin client in the morning, but I expect there is not an error on the Ignition side. What it looks like is that IE is just not handling the re-direct that Ignition generates after keying in the CD-Key. I don’t know if the IE 8 that is part of Windows Embedded is different than normal IE 8. Maybe there are certain features or plug-ins that are necessary for IE to handle it properly that are not there by default on the embedded system? Everything else seems to run fine I just can’t load the Panel Edition license on it. It will normally be used just to connect to the server as a client but I need to license Panel Edition for local only mode.

There are some errors in the wrapper file. I deleted the file and tried to activate the license again to isolate the errors and they are in the attached file.
wrapper.log (10.5 KB)

The address that is shown in IE when it goes to its “Internal Error” page is:

I was running Ignition 7.1.6. I noticed that 7.1.7 was available so I installed that and tried it again with the same result.

I then installed Firefox to see if it was an issue with IE. I got the same message so it is an Internal Error with Ignition.

I also tried the beta version 7.1.8 and got the same Internal Error.

Can someone please check the wrapper log and see if there is anything that can be done? I need to install a Panel Edition license on this system to run temporarily at our customer until the server is in place and I am headed out of here tomorrow.