[IGN-2343, IGN-8727] "Unable to send updates to clients" error in logs

We have errors over and over again in our logs for "unable to send updates to clients." We see several errors per second. The errors indicate that it is with a Perspective session, but I think that it might actually be related to editing a Perspective view in the designer.

From past experience, it doesn't cause usually major issues, and it disappears as soon as we restart the Gateway. However, we just had an issue where Ignition experienced a very momentary disconnect from our SQL Server 3 straight times when I saved our Parent project, and I'm starting to wonder if there could be a connection. Other users were able to able to save the Parent project without any issues, which makes me think it was related to my client. I'm curious now if the two errors could be related in anyway.

Has anyone seen this? Any ideas how to resolve it?

I would like to identify the root cause and eliminate it.


If anyone from IA replies, I had a ticket open earlier from this issue, but we closed the ticket after we restarted the gateway and the errors disappeared.


We are facing the same problem here.
As you said, after restarting the gateway, it stops, but after some time it starts again.

Did you manage to solve this problem?

We’re aware of the issue and the issue is in our queue for development (meaning it should be fixed sooner rather than later). The internal ticket provides no replication steps - nor does this thread - and that’s why it hasn’t been fixed previously. If anyone here can explain what caused the issue when it was first encountered it would help us immensely. We have been unable to replicate the issue internally, and so “fixing” the issue is going to troublesome.

I started seeing this warning in the status/logs after I imported a project with security. I’m not sure if it has to do with the security or the project import. Hopefully this provides some direction @cmallonee

I’m not completely honest how it starts, so I’m not sure how to replicate it. I think that it might be related to having the designer open with Perspective views open when I lose network connection to the Gateway. But that’s purely speculation; it is possible that it is related to an actual client that is connecting to a Perspective webpage.

All I know is that the error doesn’t cause any immediate issues, so we usually identify it after it has been going for a while.

I had the same problem this week. I have detected that it has to do something with connecting to session over wired network and WLAN. If I change connection while I have an open session and the project is changed after the connection change thes this error appears in the log again…

@cmallonee Do you know the status of this issue? I’ve been getting a lot of it lately, not sure the cause. I think it started when we added some Gateway-scoped scripting, but that’s just a guess.

This has always been an issue we’ve had a problem replicating reliably. We did implement a fix for it, in that we identified where the logging/warning was occurring and put in additional handling to more properly identify what is occurring there instead of the generic and unhelpful “Unable to send updates to client” message. That fix was part of 8.1.12, so you can take advantage of the fix in any version since then.

To be clear, this warning does mean that something is wrong, and the “fix” we implemented only makes the logging more clear by actually clarifying an action which could be taken to fix the issue, or at least explaining what is causing the issue. If you’re seeing these warnings now you’ll still get warnings, but at least you can now understand what’s causing the issue or what needs to be done.

One of our clients on 8.1.15 has this issue. The status log page is nearly unusable because of this warning (unless you apply filters every time). Gateway restarts helps, but like others in this thread mention, it comes back after 1-2 days.

Here’s the log expanded, which tells me it’s something with a perspective project.

Edit: Based on the warning message I checked the threads but didn’t see any blocked.

I think that the issue is related to Perspective views open in the Designer when the connection in the Designer is lost to the server. For example, if I have am editing a Perspective session in the Designer and get disconnected from our VPN, it appears that it may be the cause of the issue. However, it isn’t completely consistent, so I don’t know if it matters whether I have unsaved changed in the view or if it could be that the VPN connection is lost at the moment I’m trying to save.

We are experiencing the same error. If I use the magnifying glass icon, it sometimes references one project with a different session project, which makes no sense to me. It has flooded the logs so I cannot see when it started and make some correlation for cause. I can say that the last time I was editing projects in designer 3 days ago, I kept losing connection for some reason and then designer thought there was another person editing the views I had open upon re-connect, perhaps this is related? Designer crashed and closed on me a few times as well during this process. Also, we just upgraded to 8.1.15 last to get fixes for other problems we had. This gateway with about 10 projects is hosted on a remote server and connect over the internet without VPN to launch designer and client sessions…

In that case, you might just be suffering from random probing attacks. Very common on my public webservers.

Is there a way to determine that for sure?

Use a session startup script to log all of the IP addresses connecting to your server. Look for unexpected addresses attempting many connections.

{ There might already be a logger that will give you that information. }

Thanks for your help, Phil.

Can you give a little more detail on how to do this?

I'm getting the 'sync - unable to send updates to client' error spamming my error logs.

Looks like this was addressed previously but I'm seeing the issue on 8.1.18

I am also receiving this error in 8.1.23. It is flooding my logs. In the gateway logs screen, I have 537 pages that only go back 12 hours or so.

Could you expand the warning and paste the accompanying stacktrace here? The "fix" for this issue was to provide better insight into why the issue was being logged in the first place. Websocket disconnects are frustratingly nebulous and can occur for a number of reasons. We originally captured any sort of failure to communicate via the websocket and logged it as "Channel is not open", which was unhelpful in diagnosing the cause. We're hoping the stacktrace could provide a better idea of why you're encountering this.