[IGN-407]Brief Network/VPN Outages causing designer projects to become invalidated?

Sometimes my VPN disconnects, and I need to manually restart it. The connection might only be down for a minute, but when I get it to come back up, my project is invalidated, and then have to close the designer.

This gets really old when I have multiple designers open or if I’m trying to work on the script console for something.

Is there a setting somewhere that might adjust the tolerance so I don’t have to close my designer if its only disconnected for a minute? It’s really a hassle.

2 Likes

This is basically a bug (I’ve added this thread to our internal tracker).
As a bandaid, apparently setting sessiontimeout.designer to something higher than the default 60 (via ignition.conf parameter in the wrapper.java.additional area) might help.

2 Likes

This also happens when a Mac goes to sleep, super annoying when I walk away for a few moments, come back and have to restart the designer. Looking forward to that getting fixed!

Is there a way to also set one of these ignition.conf parameters to increase the delay before perspective clients become invalidated? We have spotty connections in the field, if the guys lose connection for a few moments their session becomes invalidated, and they are forced to re-login. We have the inactivity time set to 2000 seconds, so I am wondering if there is another parameter we can set for Perspective Clients in ignition.conf

image

Increasing the ‘Session Timeout’ settings in Perspective → General should help with that, although “a few seconds” doesn’t sound anything like the default 10 minutes. You should probably get in contact with support. Also, if you’re using the mobile apps there’s another layer on top of this.

Ok, yeah that’s where we have it set to 2000 seconds. I was just hoping you had another trick for that.

I tried to set this in my ignition.conf file, but I am not sure I have correct pathing for the parameter. Can you tell me if this is correct?

image

Did you restart your gateway after saving the .conf changes?

That’s not the correct format. That line should be something like:
wrapper.java.additional.3=-Dsessiontimeout.designer=900

Would this be correct? I’m not 100% if additional #2 being commented out affects how #3 might work

image

The actual value of the numbers doesn’t matter, as long as they don’t overlap.

It looks like this did not increase the timeout delay, it actually made it worse and my designer will prompt for an export even if is only a second or two that the designer loses connection with the gateway.

Is it possible that it is in milliseconds and not seconds?

Anything else that I can try?

Hmm, it’s definitely intended to be set in seconds throughout the code, but it’s possible there’s an issue somewhere. I think that ultimately this is just going to have to wait for improvements on our end.

I can’t recall this happening despite developing on Ignition servers via VPN over satellite with routine VPN connection losses–some definitely longer than a minute or two. I’ve also disconnected VPN for hours, reconnected on return to work, and the Designer consistently reconnects on VPN reconnection. Sorry this doesn’t tell you how to make it work this way for you, but I figured it might be helpful to know there’s some scenario in which VPN connection losses don’t seem to be a problem.

I’m also having this issue all the time. I hope to see a fix soon!