[IGN-4823]How to escape {} behaviour in SQL Query binding?

I have an SQL query where I want to replace stuff in a field’s text with {1}, however the query is thinking I have a tag/property called 1 and is then failing to replace it. How can I escape this behaviour? I’ve tried all the usual things like:


What have you tried, will this work…

query = '''
		SELECT .... {0}.....{1)

Edit, I believe I misunderstood your question, but I’ll leave the post anyways.

This is unfortunately impossible (directly). Could you put the curly braces you need in a custom property, then reference that custom property as a property reference in the query?

I did kick the old ticket I filed back in my support days for this, which might help a bit…

I ended up just using square brackets instead. I didn’t really need to use braces, I just wanted to use familiar syntax e.g. as in indirect tag bindings.

Also, i must have rushed that post as I should have included an example query… It seems you understood it though, but here anyway:

SELECT REPLACE(field_name, 'thing', '{1}')
FROM table