[IGN-4949] PowerChart tag browser start path doesn't load initially

On the PowerChart, the filter path for the tag browser doesn't seem to load the filter on inital page load, the format is valid because if I click the refresh button it will filter correctly, it just seems like an unnecessary step. The filter is configured with a script binding that only takes 2ms to process so I don't think that's the problem.
Before Refresh:

After Refresh:

We’ve got the same problem on 8.1.3.
Any update on this problem ? any workaround ?

this is still an issue in 8.1.23

a workaround:

It actually doesn't always work. I could swear I got it working with this method, but I'm not really sure anymore.
I ended up hard coding the start path to make sure things go as planned.

Yes it doesn't work in a in a repeatable manner.
A true fix would be welcome !

1 Like

Anyone got any updates on this bug? :slight_smile:

As previously mentioned, it seems like the start path does not always load correctly. Sometimes we need to press the refresh button to have the tag browser showing the correct structure, even though the path is correct.

Have tried setting the start path on the startup event of the power chart, via binding to a session property that is set in a session startup event, via message handling etc. All methods giving the same result, with the structure not loading as it should once in a while.

My ticket #67582 has been closed but this issue still exist