[IGN-6087] Date picker issue (selected date - 1)

I am currently facing issue related to Date picking whenever i pick one date from calendar for first time it takes (selected date - 1) , so need to select twice .You can see this issue in attached video. I have 8.1.15

this is perspective browser session. i am facing same in designer preview.

Hi Aditya,

I don’t seem to be getting the same issue on versions past 8.1.15, have you checked those versions since by any chance? There doesn’t appear to be any known bug reports for this kind of behavior either.

Have you also confirmed there aren’t any scripts or bindings on the component that could be causing this?

Hi @Aditya_Patil,

There may be some issues with time zones here. What time zone do you have your session prop set to and what time zone is your application physically running in?

NO sir , I have created new project on same gateway , as well as i have tried this on two different gateways results are same :pensive:

Hi Joseph Cressa,

Above footage is recorded in IST timezone.

  1. What is the timezone of the Gateway?
  • Gateway time zone is UTC
  1. What is the locale of the project?
  • Browser
  1. What is the project timezone?
  • Gateway Time Zone
  1. In the perspective Session Props, what are the values of ‘locale’ and ‘timeZoneId’?
  • ‘locale’ - en-US
  • ‘timeZoneId’ - UTC

Your images are broken because you copied links that start with a cisco security URL. Don’t do that if you expect anyone outside your organization to see them.

Hi @Aditya_Patil,

We’ve been able to replicate the issue locally; we will get a ticket filed and keep you up to date when the issue gets fixed. Thanks.

Hi @ayu, For you is it possible to share gateway backup.On which you are able to simulate this issue. It would be great help :sos: as i am not able to handover gateway backup because it is happening in production environment :face_exhaling:

Hi @Aditya_Patil,

There wasn’t anything special with the Gateway I had used. I used the exact same settings you have regarding time zones and locales and just had a simple view with one date time input. The only thing I had to do to replicate this issue was change the time zone on my operating system to IST.

Yup, @ayu I have raised ticket but inductive says they are not able to replicate this issue so they were asking for gateway backup which i am not able to give as its production environment. So … . Have u raised ticket for the same issue ?

Hi @Aditya_Patil,

I haven’t created/raised a ticket yet, but let me get in touch with support to see what they’re seeing differently. Just for some additional context, I have tested 8.1.16 and 8.1.17 and the issue still exists.

Thanks, I have raised ticket they told me that they have created bug ticket for this issue ,in future updates it might get solved.

Is there any solution or fix provided for this issue?

Inductive said it is a bug and they are working on it.
It will be fixed in upcoming releases.

Still there is no feedback in which version they will fix/ have been fixed.

Ok. Thanks.
@ayu, could you please provide update on this? I’m using 8.1.14 version and seeing the same issue with date time input component. Is this something to be resolved in future releases?

Hi @Khushboo_Amarnani,

Yes, a ticket has been filed. However, I don’t have any more details or information or when this will be worked on.

@ayu , Thanks for confirming. But how do we allow the user to select current date from date time picker now? We have an urgent deliverable, where in the user should be ale to select current date from picker.
It would be really helpful if you can provide some solution for this issue. Or direct to the concerned person looking into this issue.