[IGN-6521]Unable to Search Through Vision Dropdown Component with Keystrokes

Hey all,

I have two Gateway servers currently (8.1.15 and 8.1.18) and the problem I am experiencing is with 8.1.18. I am unsure if something with the component in the backend has changed, but I am no longer able to search through a dropdown list by typing like I was able to in 8.1.15:

I typed ‘0904’ and I was able to instantly select the item. Same thing with ‘0906’


I tried the same thing as above, and it only scrolled down when I typed a number or letter that those items began with. All the items began with a ‘0’, so everytime I hit a ‘0’, it scrolled down one item instead of trying to find an item with the list of characters I typed.

I am not sure if this is a bug or a feature that has changed, either way, I think it would be kind of redundant to program a script for every single dropdown component I have (50-100 in one project out of ~10 projects).

Any help is appreciated!

The ‘search like’ functionality was deliberately removed because it was buggy (in particular, typing a space would ‘reset’ the search buffer, leading to unexpected results). However, you’re not the first person to complain, so we may end up reverting that change and accepting the occasionally buggy behavior.

For context, the KeySelectionManager that drives this logic is very deliberately written to only allow single-character selection, not searching based on a buffer: JComboBox.KeySelectionManager (Java SE 11 & JDK 11 )

Ahhh I see; that would explain everything. Maybe have a property to enable/disable ‘search like’? I am sure there are some who don’t necessarily need this functionality, but then on the flip side there are those who have huge lists of data and would benefit from a feature like this.

Anyways, thank you for the quick response so I didn’t go down a rabbit hole trying to solve this!

Hi there,
Since upgrading from version 7.9. I have had many users ask about this topic. We have many vision dropdowns where this ‘search like’ feature worked great for my users to be more efficient at entering data. I would really like to see this feature come back in some form.


I’ve created an internal ticket (you two aren’t the first who’ve asked) to see if we can revert to the original behavior without some of the other drawbacks that caused it to change in the first place.

1 Like

Is there any update or estimated time on this request?

The revert was done recently; I'm not sure the exact version but I believe 8.1.23 will have it; possibly 8.1.22.

1 Like

@PGriffith whether this issue fixed in 8.1.23?

It's back and as far as I can tell, it is behaving the same as before.

1 Like

This seemed like an interesting problem, and I had the night off, so I fiddled around with this and developed a prototype searchable combo box:

While I was at it, I made all of the colors for the dropdown, textbox, and button all independently accessible:

I also added a maxRow property that makes the number of rows displayed variable:

...and the width of the dropdown automatically adjusts to the width of the text

Just in case anybody else wants to play around with this and develop it further, here is the working prototype:
prototypeSearchableDropdown.zip (7.2 KB)


Are you using any project library script?

Its missing in your zip file you have attached

No; everything is self contained, and I've imported the template and tested it on multiple systems, but that said, I'm sure there is a lot of room for further development.

Are you getting some kind of error?

yes getting error

tested in ignition 8.1.17

passed dataset



whether i missing something?

Yes. The way this dropdown is designed, it requires two columns: Value and Label. Value is an integer, and Label is a string. If you need it to work in some other way, the script will need further development.

The core script is a custom method on the text field component.

1 Like

Oh ok fine.. thanks for the input

1 Like