Ignition 7.7 on Linux

Is anyone else having trouble?

The 7.7 gateway status is faulted on a fresh install of Ignition 7.7 on Ubuntu 14.04 x64. This is the installation script I used that worked fine for 7.6.6.

[code]# install MySQL
export DEBIAN_FRONTEND=noninteractive
apt-get update
apt-get -y install mysql-server

install Java 7

apt-get -y install openjdk-7-jre

install ignition

wget http://archive.inductiveautomation.com/ia.public.key
apt-key add ia.public.key
echo “deb http://archive.inductiveautomation.com/apt ignition non-free” >> /etc/apt/sources.list
echo “deb http://archive.inductiveautomation.com/apt ignition-beta non-free” >> /etc/apt/sources.list
apt-get update
apt-get -y install ignition[/code]

Thanks, Craig
wrapper.log (44.9 KB)

Hi Craig,

Ignition 7.7 requires Java 8. It looks like you are using Java 7.

Ignition 7.7 has been running well on my Linux system.

Rats, missed that bit. Thanks for the assist.

I would like to share this test which may help others.

Successfully tested integration of Ignition 7.7 on Ubuntu 14.04/64 bit headless server and KepsrverEx/OPC-UA on W7.

  1. OS: Ubuntu 14.04/64 bit headless server, ip address

  2. Ignition 7.7/64 bit linux

  3. KEPServerEX 5.15 on W7/32bit, ip address

4 Java 8 required on both server and client.

  1. Reference guide: inductiveautomation.com/sup … n_guid.htm

I followed the guide in the above link but the KepsreverEX connection status was still in fault. Then i tried the following:

  1. The default ip address on the Configure/OPC-UA/settings page was incorrect. Changed it to Ubuntu server ip address Check screen shot 1

  2. The default ip address on the Configure/OPC-UA/certificates page was incorrect. Restarted ignition, ip address automatically updated, regenerated all the 3 certificates, downloaded the client certificate and finally imported into KepserverEx trusted clients page. Check screen shot 2

  3. Turned off W7 firewall, edited and saved the OPC server connection page and the status changed to CONNECTED. Check screen shots 3, 4 and 5.

  4. In the W7 firewall page, allowed the program “server - runtime” from the “C:\Program Files\Kepware\KEPServerEX 5” folder to communicate through Windows firewall. Turned on W7 firewall.

  5. Everything works fine.


Kepserver trusted clients page for my above post. Pls note that i have 2 clients.

  1. “ignition 7.7/32bit/windows” on my W7/32bit local machine (
  2. “ignition 7.7/64bit/Linux” on Ubuntu 14.04/64 bit server (

Both OPC-UA clients work fine.

Make sure that the “Endpoint Address” in the “Configure/OPC-UA/settings” page has the local Ignition server ip address. In a headless Ubuntu server/64 bit installation, it does NOT update the server ip address automatically. Needs to be edited manually, restart ignition and reinitialize Kepserver.

After this, Kepserver identifies automatically all the ignition servers running on the LAN in the trusted clients page.