Ignition 7.8 on Ubuntu 15.10

I successfully installed Ignition 7.8 on Ubuntu 15.10.When I tried try to run clientlauncher.sh from terminal I got this message:
"/home/shrikant/Downloads/clientlauncher.sh: line 126: declare: /home/shrikant/Downloads/clientlauncher: syntax error: operand expected (error token is “/home/shrikant/Downloads/clientlauncher”)
Client Launcher : The locate database is either non-existent or out of date. Please enter the root password to run updatedb (may take a few minutes to complete).
Password: "
I tried both “password” and Ubuntu password as password. Both times I got this message:
"su: Authentication failure
/home/shrikant/Downloads/clientlauncher.sh: line 126: declare: /home/shrikant/Downloads/clientlauncher: syntax error: operand expected (error token is “/home/shrikant/Downloads/clientlauncher”)
Client Launcher : This application requires a Java Runtime Environment Would you like to visit the java download page?

  1. yes
  2. no
    Similarly, when I try to launch designer from .jnlp file a window with “Open with” dropdown pops up. Does it have something to do with JRE version. Output of java -version command in terminal is:
    java version “1.8.0_74”
    Java™ SE Runtime Environment (build 1.8.0_74-b02)
    Java HotSpot™ 64-Bit Server VM (build 25.74-b02, mixed mode)

How can I fix this issue? Thanks in advance.

Your system is acting like it has a hard time finding the Java JRE. How was the JRE installed? Is it Oracle Java or OpenJDK Java (or something else)? Where is the JRE installed (run “which java” to find out). Any details you can give would help.

Hello, Before posting the reply I just ran the same command mentioned above and voila! the Client Launcher windows popped up. But there was no gateway to select. So I typed gcu in terminal and after some delay (found that unusual, expecting to launch that quicker, anyway) Gateway Control Utility window popped up but I do not see Start, End buttons in top right corner, there is Restart link but it doesn’t start the gateway.
So my original issue seems to have solved but there is this new issue of gateway not running. Can you please tell me how to solve this? Also, how can I launch gateway on startup?


The Start and End icons on the GCU are only present on the Windows version of the GCU, as they start and stop the Windows service that controls Ignition. What you need to do is run ignition.sh in the installation folder to get the Gateway going. Ubuntu has switched to the systemd service startup system, and so requires the systemd way of autostarting the Gateway. We haven’t yet updated Ignition to autostart with systemd, but there are lots of examples out there that you can set up on your own system.

Edit: Here is an example of a file you can use for systemd. You would save this file to /etc/systemd/system/ignition.service

Description=Ignition Gateway

ExecStart=/usr/local/bin/ignition/ignition.sh start
ExecStop=/usr/local/bin/ignition/ignition.sh stop
ExecReload=/usr/local/bin/ignition/ignition.sh restart


Then install the service. This will also allow the Gateway to autostart when the machine starts.

sudo systemctl enable /etc/systemd/system/ignition.service

To start manually, run:

sudo systemctl start ignition.service

To stop manually, run:

sudo systemctl stop ignition.service

To check the status of the service, run:

journalctl -f -u ignition.service
1 Like

Thanks. It worked!