Ignition 7.9 GCU doesn't work

I made the classic mistake of changing the roles’ names and then log out, now I can’t access the Gateway. I tried using GCU to reset the user/password to admin/password but it doesn’t work, actually not a single GCU command works. Also GCU’s gateway status is wrong: it says its offline when it’s online.

Try right-click > Run as Admin when launching the GCU.

This might be a dumb question, but you posted as Ignition 7.9, but are you on Ignition 8+? The gateway you have shown is for Version 8. I also thought in version 8 that the GCU is no longer available, and was replaced by the command-line utility (notable still GCU - tisk, tisk IA - very confusing). If you have the Gateway Control Utility, I don’t think it works with 8. I haven’t dived into 8 territory yet, so I’m not familiar with what’s available. I also thought that with Ignition 8, you would need to use the Gateway Command-Line Utility instead (https://docs.inductiveautomation.com/display/DOC80/Gateway+Command-line+Utility)


Good catch @Herbie! That is not a 7.9 gateway and there is no graphical GCU for 8.0.

Thank you @Herbie, I panicked a bit and I saw the first folder in the Program files directory with the Ignition name on it and I thought it was the right installation folder. Today I scrolled down a bit and I saw the Igniton folder with the 8.0 files. I used the gwcmd -p command and it worked.
Thanks everybody

1 Like