Ignition 8.0.2 Vision Client Launcher doesn't wait for Gateway running

We have an on-machine HMI that runs the Ignition 8.0.2 gateway as well as a single client on a limited 1 client system (OS is Windows 10). A full screen app shortcut created by 8.0.2 Vision Client Launcher on desktop starts the HMI as expected. We copied this shortcut to C:\Users\Administrator\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup, expecting it to launch the client on Windows startup as on other units running Ignition 7.9.9. Instead, we’re getting this (which we don’t see when we run the shortcut ourselves):


And at the end of the countdown we get this:
image
Here’s the app config with names mostly blanked out (we tried increasing Timeout, but it doesn’t seem to apply at the stage this is failing–tried 600 s and still the same result, though Windows restarts in less than half that time):

We can run a cmd script on startup to run the app after a delay, but I expect this isn’t supposed to be necessary (see this post–though I don’t think it’s the same kind of problem this time as it occurs whether or not there was a client running immediately before restart). Is there something we can adjust/change to get this working, or is this a bug/regression in the 8.0.2 Vision Client Launcher?

FYI we get the same error message if we try to manually start the app too soon after Windows restart. It’s ready somewhere between 30 and 60 seconds after Windows startup and we no longer get the error message if we wait long enough to start it (via script or manually). It’s definitely an issue of client launcher not waiting for gateway to reach running state as the following script resolves the issue:

:: Checks for Ignition Gateway running before opening app.
:: Run from link in "C:\Users\userName\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup"

:: Parameters
@echo off
set host=localhost
set port=8088
set clientLauncher=C:\Users\Administrator\AppData\Roaming\Inductive Automation\Vision Client Launcher\visionclientlauncher.exe
set app=App Name
set /a count=1

echo Waiting for Ignition Gateway...
:checkStatus
powershell -Command "(new-object net.webclient).DownloadString('http://%host%:%port%/main/StatusPing')" | find "RUNNING" > nul
if errorlevel 1 (
  set /a count+=1
  echo Check %count% - Ignition Gateway is starting...
  timeout 1 > nul
  goto :checkStatus
) else (
  echo Ignition Gateway is running. HMI starting now...
  "%clientLauncher%" "-Dapplication=%app%"
  :: Leave message on screen long enough for operators to see app starting.
  timeout 10 > nul
)

Output looks like this:
image

2 Likes

You can also do it in the Task Scheduler with delay at Windows startup…
https://www.maketecheasier.com/start-scheduled-tasks-with-delay-windows/

But with @witman script you have visual feedback, while with Task Scheduler you don’t…

It looks like this regression should be resolved in 8.0.6, though I won’t be testing till 8.0.6 is the stable release:

15036 Launcher respects retries, added new modal with feedback Fixed an issue where Client Launchers weren’t respecting timeout and retries settings when attempting to target a gateway that isn’t running. Additionally, added a new modal that provides feedback about the attempts

Ignition 8.0.6 Stable release resolves this issue with timeout set high enough in Vision Client Launcher settings to ensure gateway has time to start:

Still having this issue in 8.0.7, but the batch file got us up and running for now.

I’m glad the batch file got it up and running, but am surprised you’re seeing this on 8.0.7. We’re also running 8.0.7 and have not seen this issue since 8.0.5. Did you try setting the timeout higher on the application link (screen clipping I shared above just sets defaults for new application links)?

@witman I’m getting this error even after increasing the Timeout and Retries

image

In the visionclientlauncher.log it doesn’t looks like it’s waiting the 60 seconds before it gives up.

That does look like the same issue. If you check About link near top right of the Client Launcher, what version does it show?
image
It’s easy to forget, but the client launcher upgrade is a separate install after upgrading the gateway.

I’ve been meaning to reply, but that was exactly my issue.
I failed to upgrade Vision Client Launcher to 1.0.7
Once I did that, we no longer saw that issue or needed to use the batch file.

Thanks for your help!

3 Likes