[Ignition 8.0.7] Active pipeline not triggered for the first time each alarm occur

I have an application upgraded from 7.9.13.
When I restart Ignition, I have an alarm pipeline associated for the active state for multiple tag alarms.
When each alarm became active, the first active state of each alarm doesn’t trigger the pipeline.
The second one is ok.

I suspect that the initial active state is filtered ?

In 7.9.13 I don’t have this behavior.

@Paul.Scott Is there ever a bug reported for this ?

Thanks for the report! Sorry about the delay: the post came right as I started vacation.

Not that I can see. I know this was a while ago, but any other details? Notable errors in the gateway? I can try to have some folks replicate internally, but any other details you may have are appreciated.

I’m pretty confident what’s occurring here is expected. I have also confirmed the behavior is the same in 7.9.13 as it is in 8.0.8.

The first subscribed tag value after startup is considered an initial event, which by default doesn’t enter the notification system. These events will result in notifications if “notify initial events” is enabled and the minutes passed since shutdown exceeds the “continuous event detection window.” New active, unacknowledged events won’t be generated if this detection window hasn’t been exceeded, since the original alarm event prior to shutdown will be retained, hence why a notification isn’t sent.

So to summarize, if these alarms are active on shutdown, and then the Gateway is restarted within the event detection window, it is expected (with default settings) that, on startup, the prior event is loaded, and thus no new event occurs, hence why no notification is sent. If the Gateway is restarted outside the event detection window, new events will be generated for these alarms, but won’t enter its pipeline if notify initial events is false. If the alarms weren’t active on shutdown, then new events would be generated on startup (being that now active) and, similar to before, would only enter its pipeline if notify initial events is true.

If you’re wanting new active events to be generated always on startup and for initial alarm events to enter their respective pipelines, then it would be best to set the detection window to 0 and notify initial events to true. Both of these Gateway settings are under the Event Suppression category in Alarming -> General.


Thanks a lot for these clarifications.
Notify initial events was set to False in v8.
I will test again

Kurt, what is the largest number that can be placed in the continuous event detection window?

This is equal to Java’s Integer.MAX_VALUE, which is 2147483647.

2,147,483,647 minutes would equal to about ~4,086 years.