Ignition 8 can't run on raspberry PI 3 B+

I try to run the ignition 8 on raspberry PI 3 B+.
After running ‘./ignition.sh start’ , I can connect to server through my laptop browser and set user and password. At this moment ignition try to startup and fail.
I also decrease the size of java memory to 128/256 if the issue for limit amount of memory in RPI.
Does anyone else try to test ignition 8 on RPI?

Can you attach the wrapper.log file?

Here you are:
wrapper.log (49.4 KB)
system_logs.idb (51 KB)

can you delete the file at /usr/local/ignition/data/certificates/cert-chain-store and try starting it again?

I tried and failed again. I also have 450M free memory left.

Is it the same error in the logs? Can you delete it again and try starting with sudo ./ignition.sh start? There seems to be some problem with the keystore or certificate that’s generated.

That’s exactly what I did.
It seems to me the log is the same.
If you need any other test just tell me.
system_logs.idb (69 KB)
wrapper.log (14.2 KB)

Not sure what’s going on, we’ll have to load the latest build on a RPi here and see if the same thing happens.

I use version 2018.03.29

Hi Kevin
When do we get an update on this?

I am currently investigating this alongside other reported issues on ARM devices. Ill let you know if I need anything else during this process.

Jonathan C

I can’t replicate this issue on our RPi in-house (which is running Raspbian) using 8.0.0-rc1, just have a couple of questions for you regarding your install:

  • Are you using the ARM zip from the downloads page to do the installation?
  • Which OS (and bitness) are you using?

Yes I download armf 20180329 but the beta version.
I use Rasbian os.
I will try with 8.0.0rc1 and let you know the result.
By the way is there any procedure to uninstall previous version or I just need to delete the files in /use/local/ignition/?

I test rc1 release today and it works perfectly.


I could not find this directory. The installer created this directory: