Ignition Apps Ubuntu Touch Screen

I have a Mitac P100 touchscreen PC running Ubuntu (I have tired 18.04 and 20.04) and the touchscreen works fine for everything except IA client programs. I have tried it with the Vision Client and Perspective Workstation. None of the buttons will respond to presses. If I hook a mouse up everything works like a charm. Has anyone run into this issue before? Any solutions out there?

What event are you trying to use on the buttons (actionPerformed, mousePressed, mouseReleased, mouseClicked, etc…)?

Touchscreen drivers generally just turn presses into mouse events of some kind.

I’m having issues within the program itself not my projects. For example I can’t click on the “Add Application(s)” button or if I have already added an application I can’t select it and click “Open Application”. If I plug a mouse in I can launch a project and within a project I seem to be able to click on things just fine. I made a quick test project and put a multiStateButton on the page and I can click through all three states no problem. Also all the buttons on the app bar respond to presses.
Quick additional test I just did. I added a button with an onActionPerformed refresh event and it works no issues. I changed it to an on-click event and it also worked

Support for the on screen keyboard was added recently (the nightly from 2/24/2021) which also included a fix for this issue. you could use the nightly version if you need this functionality immediately, otherwise you could add -Djdk.gtk.version=2 to the perspectiveworkstation.sh script in the app directory to get touches to work in Workstation on the management side. If you launch a perspective session you may hit some inconsistencies without the changes that were brought in for that nightly.

Ok Awesome. I will spin up the nightly on my dev server and see if that fixes my issue